Thing configuration is not persistent - gone after restart - please help

  • Platform information:
    • Hardware: Mac Mini 2012
    • OS: High Sierra
    • Java Runtime Environment: Zulu 8u163
    • openHAB version: 2.3
  • Issue of the topic:
    Thing configuration is gone after restart. I noticed that behaviour on in the following bindings that don’t provide a configurable .cfg or .thing-file:
    Sony Binding. Issue: auto ignore is set to analog after every reboot. I’d like it to stay at “none”.
    Really important one: Z-Wave binding: My Fibaro Roller Shutter 2 is not working correctly with the standard config -> It is falling down after i stop the shutter at any position. I made changes to the parameters (delay time, motor operation time etc.) and it works properly now.

But:
After a restart of OH these changes of bindings only configurable via paperui or habmin are set back to standard values …

Is there a way to change this?

Thank you!

  • Please post configurations (if applicable):

Sony Binding (i don’t want analog channels to be ignored because i control the volume and mute).
Z-Wave Binding

Where do you set this parameter? in PaperUI Thing config?

These settings should be stored in the jsondb. Can you see these parameters being stored there?

Those changes to ZWave parameters are not stored in the binding (or any other part of OH) but in the devices themselves.
If a OH restart resets them, you possibly failed to properly save them. Use PaperUI to configure and cross-check with habmin or vice versa.

1 Like

Hi!

I attached a screenshot.


It’s set in Paperui in the Thing config, right.
I will have a look at the json db. thanks

good to know!
Strange behaviour then. there was noting changed in the device. (no power loss, no reset or anything …)
I’ll reboot and take a look.

find file /var/lib/openhab2/jsondb/org.eclipse.smarthome.core.thing.Thing.json and check if your settings are saved properly (after you edit them with the UIs)

It should be something like: device -> configuration -> properties in the json file

1 Like

okay i am one step closer to the goal.
It seems that after this reboot the z-wave devices have saved the config.
(strange they did not before …)
i looked at the json file and at least for my tv the settings are not saved.
can i edit this file manually without producing any issues?

EDIT:
The changes from the TV are stored. But after a restart they are gone … strange.
Seems like there is some kind of an init or so :wink:

hm …
So the z-wave device works now as desired but the TV does not. It stores the chanes in the json db but after restarting OH the old values are there for acces code and ignore channels. IP adress and mac adress are saved.
I asked in the thread. Maybe the developer responds.
Thanks a lot!