Time to say Goodbye

Sorry Developers,
But I think it’s time to say goodby to Openhab.

For the third time after an update I had to reinstall the whole server because of missing Java libraries (I have used openhabian before, now I switched to docker).
Then after the new installation and restoring of my old config files. Over 50 % of the bindings are failing.
Nearly nothing works!
On that occasion I thought that before I could get the old V1 bindings running again, I would switch to V2.
Then I came out of the frying pan and came out in the fire.
OWFS binding -> nothing works! Maybe it just doesn’t work because I have too many sensors in my house with 150?
Then I tried the new MQTT Binding. After 2 days of frustrating trial and error if found a forum thread, with the comment of a developer that the required property is not included up to now. Then I had 2 items partly working! But after restarting the docker image the bridge reports “UNINITIALIZED - HANDLER_INITIALIZING_ERROR java.security.NoSuchAlgorithmException: Algorithm is missing” Äh, It has worked before restarting the docker image and now an Algorithm is missing? Probably got eaten by a mouse?
BTW: I restarted it, because the Fritzbox binding suddendly was no more able not connect to the Fritzbox. This worked after the restart again but not for long!

Before I used Openhab, I have programed all by myself in python, node-red and javascript and I will go back to this. Because that way my work won’t be destroyed by any updates.
I’m a IT hardware developer, working with C, Python, SQL, javascript etc. but I have no knowledge in JAVA.
Unfortunately nobody told me that this is obviously necessary to work with Openhab. Pity!


Being an IT hardware developer your light years ahead of me,:laughing: and like you I know nothing about JAVA. What I do know is OH works great when I have everything setup and stop trying to jump on every update/upgrade. I do want all the latest features so I use a second server for testing and upgrade (my main server) only after I have it working with my setup.

Sorry to see you go and wish you the best.



Same here, no Java knowledge…

I have no Java knowledge either… Infact, I had no knowledge about openhab, when I started 1½ year ago. Not even Linux. And to my understanding, working with openhab, specially with updates, snapshot etc… You do have to know some linux more than Java… I will never learn Linux. I hate it, I dont get it… It´s too difficult for me. If it wasn´t for the community and sometimes Google, I would have given up on openhab long time ago… But guess what. Im still here… Still knowing almost nothing about Linux, and zero Java, Python, C, Javascripts etc…

You did make me wonder though.
You´re a hardware developer, knowing C, Python and more… But, somewhere you seem to have missed the part that says, backup… I admit, I know nothing about C, Python etc as well. But I do know about backups. And I have a slight feeling, those who do develope, no matter what code language, they know about backups as well. You seem to have missed that part. Thats really sad, cause I believe it could have saved you alot of extra time, and probably frustrations as well.


Dear Erich,

„Nothing works“ is a bit difficult to fix. For me the OneWire binding works. On the other hand, I only have around 70 sensors. I do not think that there is or should be a limit anywhere near these numbers. I‘m always willing to fix every bug, but you have to be a bit more specific in what is going wrong. In case you want to work that out with me, please open a single thread for your OneWire issues.


The algorithm is probably not eaten by a mouse but unavailable because the container uses a limited cryptographic strength policy by default (due to local laws and export restrictions). See Java cryptographic strength policy.

Well I get your frustration and I can understand it.

before any update -> BACKUP or assume it! (you said you are a programmer so you have literraly NO EXCUSE each programmer is aware of this rule!)

First you should assume your responsibilities.

Of course sometimes there are some breaking changes/bugs… but it’s an open source project done by great volunteers for you, for me and for tons of other people + themself.

You are not happy with that ? Then as always PR welcome! You can write integrations/non regressions tests in python if you want haha I’m sure the help will be accepted.

Just remember -> you got it for free. Theses guys are doing it during their free time meanwhile you are maybe drinking beers or having fun with your friends. They really invest their personal life (at least some part of it) to produce it so I would expect some respect to them.

If some developer come and read this: Thank you for doing it !


And why did it work before the reboot?

That’s what I thought this argument was gonna come to!
But also my time is not for free! I have had a working system with about 150 items.
You’ll confirm to me that this isn’t set up in a few minutes. It’s the third time a simple update has paralyzed the entire openhab system!
All the holidays I’ve been working on trying to rebuild the system. At some point I gave up frustrated and wrote the thread above.

And yes I have a backup of my old system. But it is useless! When I restore it and update it again, I will sureley at the same point as I’m now. And not to update a system is a big safety hazard.

And I’m not the only one! The whole forum is full ot threads with complaints about failed updates
… and so on…

And please have a look on https://github.com/openhab/openhab1-addons/issues/5507
Here a desperate user is presented as not being able to read, but there is no reference to “manual installation” on the mentioned page and the links on the mentioned pages are broken.
By the way, this problem was one of those I also failed to solve and the consequence of the user is exactly like mine - do it yourself.

I don’t need the newest features but the newest security fixes! If your server is connected to the internet and you don’t install the latest updates you are playing russian roulett! Not my prefered case!

Nice that you are knowing about backups - I’m too!
And rest assured, I even store my backups off-site to be save in case of fire.
But what good is a backup if I can be sure after the restoration that a simple apt upgrade will send the server back to the eternal hunting grounds?

If you don’t want to upgrade your openHAB when you do an apt upgrade then use apt pinning or simply remove the openHAB repository from your apt sources.

I have disabled the OH repository in /etc/apt/sources.list.d/openhab.list and only enable it if I have the time to adjust the system after an upgrade, so I can still update all other packages.

1 Like

This you can use to troubble shoot, and nothing else. But the backup prevent you from starting all over, cause starting all over ending up the same, does not really make any sense at all.

That’s good advice.Too bad it’s necessary.

For clarification: The original and fundamental mistake is not that any binding no longer runs, but the entire openhab runtime system was destroyed after a simple apt update (“Unresolved requirements”).
I have searched for the error in the forum and it showed that the error occurs very, very often (50+ results for “Unresolved requirement”), and in the most cases the only solution is to reinstall the whole system. Pitty! Especially since I am using a quite ordinary openhabian installation on a dedicated server(Pi) due to negative experiences with my first openhab installation on my home server.
When this error (Unresolved requirements) occured for the first time I tried for hours to bring back the system again without success (as mentioned I have no JAVA experience). Deinstalling/Reinstalling of JAVA, de/reinstallation of openhab etc. nothing solved the problem.

In order to avoid these difficulties in the future, I have now used the openhab Docker image. But like I said, I came from the frying pan into the fire. After restoring the config from my backup (Yes, I have one (actually more than one)), only a handful of my 150 items were still working out of the box.
I thought this would be a good opportunity to switch to V2 if available.
Since the majority of my devices are onewire, I started with the V2 Onewire binding. After installing and configuring the binding 2 in - words two - of over 100+xx devices where found in Paper UIs Inbox. That’s why my statement was “doesn’t work”.
The fht binding, even listed under FHT Binding was untraceable. The MQTT binding, even though it worked for the first time, said goodbye after restarting the Docker Image (necessary because of a problem with the Fritzbox binding) with the above error message… Frustrating!
I can’t imagine it being just me!

I‘m still willing to help with the OneWire binding. But since discovery works for a lot of people, something must be different in your setup. Either you have a lot of sensors that are not supported (if so, just let me know and we‘ll find out how we can add them, some are easy, others need more work and take some time) or for some reason they are lot listed in the owfs (that could be due to DS2409 hubs or similar, this is on the list but will take some time.

I must say that I understand your frustration, I am also experiencing that openhab is automatically updating itself, and that things are just not working after that, and that I will have to do some re-adjustments and restores and backups and backups of backups. And this now for a year and a half of using it. Somehow I manage to fix it all, just to discover that something else is not working then, and then I get a lot of recommendation to update to some dev version where it is fixed, but to expect some unstability as it is not stable version etc. So I do understand your frustration.

Having that said, I think that with openhab project and the community here, I for the first time understand the meaning of, as you say, expected reply “this is opensource, submit a PR”. Because, it IS opensource, and each and everyone of us using it can/should contribute somehow to the project if we want it to progress. Because that is the ONLY way any project can progress forward.

I was myself writing custom script when I started with automation, and then I went to domoticz, and come here, and added node red, and am now learning dockers and linux, and perhaps virtual machines and what not… All total overkill to achieve simple automation of lights, I am sure you see that I understand your point, a lot of wasted time for simple things.

However, only alternative I would eliminate this frustration is to, as you come to the conclusion, develop things myself and control it. But then some system update happens and I also have to fix some environment issue, and then I reaaaaaly want to use google assistant as I have it living room and also on my phone all the time, and to develop that integration I bet I would use 300x more time then fixing autoupdate, and docker, and java issues for openhab. And at the end, I would not be a google assistant master, and it will work well until the first time google updates something (and I noticed on my phone that assistant is broken after every time they update the assistant). And then I would use more time on that, and never get the time to integrate new Ikea switches that I really want to use as they are cheap and good enough for my applications. And if I would to develop that from scratch, I am pretty sure I would have a lot of frustration as “nothing works” with Ikea (again, each update from ikea something gets reset or missing or what not)… And there is vacuum cleaner, and the list goes on…

Much more wasted time here, and lets be honest, I would never make it work very good alone. This is where I would rather be a part of some team (any team), and the community here, both users and developers is something I never experienced on any forum/community.

I am not saying use openhab just because it is not the worst option out there, but you should consider alternatives before you just delete everything and starting from scratch, as anything pre made can get you up to 90% at the best.

I am afraid it might not be OpenHab that is under delivering, I know I am the first in line that is over expecting.

P.S. If I would to trade flexibility for reliability/convenience, I would consider Vera home control system.

1 Like

maybe another way to upgrade.

Instead of upgrading openhab, you can use ansible to install openhab from scratch and configure it completly automated. For me this is a much safer way, because it always starts from a defined root base. Means no old caches etc… and you can test it before in a virtual machine. Details can be found here.


I really wonder if someone outside of the US can package the docker image. It is clearly not forbidden in the EU.