Time zone problem

When the time zone changed Last Sunday in the US, the computer openhab is running on correctly updated the time for daylight savings. Openhab is now running an hour behind.

I really don’t want to change all of my rules :-).

I have the correct timezone, I have -Duser.timezone=, the server itself is on the correct time.

any suggestions to fix this? I updated to 1.8.2, still the same problem.


You should use the ntp binding, no -Duser.timezone and the correct setting for ntp binding, like

DateTime    Date    "Date [%1$tB-%1$td %1$tY %1$tT]"    <calendar>    (All)        { ntp="Europe/Berlin:de_DE" }

That should be enough - at least it lasts here in germany.

Thank you for responding. I took a couple of days to play with this and unfortunately, this doesn’t solve the problem.

Perhaps, my descriptions wasn’t clear. The timezone I live in and the computer Openhab runs on, report the time as 8:00 AM. Openhab reports in the logs, from the moment it boots, as 7:00 AM. this means that a rule that is supposed to start at 7, in the timezone and on the computer, doesn’t start until openhab has the time as 7, which is an hour later.

I don’t see how the NTP binding, influences this (and indeed it doesn’t) since the binding start later in the start up sequence. It could conceivably reset the internal clock for Openhab, but it doesn’t. The problem is that the Openhab internal clock is off by an hour.

I am experiencing the same problem. It appears that -Duser.timezone does not adjust for day light saving time.

The only workaround I could find was changing my time zone forward or back depending on day light saving, but that means editing the -Duser.timezone setting twice a year.