Timeline picker to setup heating, light and so on

Hi Tom,
have you set the name for sunrise and sunset items in the timelinepicker admin?

I did not, but I also can’t find in your documentation how I should do that? If you say tlp admin, you mean the “gear” widget for that tlp, or do I need to look somewhere else or pass these parameters via the webview url?

Also, do this need to be switch items (i.e. linked to the astro:sun:home:rise#event channel), or DateTime items (i.e. astro:sun:home:rise#start)?

Sorry, I’m sure I overlooked something pretty obvious.

Best,

Tom

Upon reading the OP again, it finally clicked for me and I was able to add the admin widget to my sitemap and set the sun items. Let’s see if things work out tonight when the sun sets :smiley:

Nice. :+1: Is you aware that you can adjust the time for each timelinepicker with an offset. In the regular view of the timelinepicker the gear icon. There are two slider for offsets for sunrise and sunset.

Do the DateTime items for sunrise/sunset work wih UTC times? Today, sunrise was at 06:11am (CET), but the light is still on at 6:45am…

I have never tested with UTC. Perhaps someone else. But you can Check the functionality without waiting. Mark the complete day with state ON and sun. With this condition the Outdoor Lampe should be immediately ON after saving the tlp.
Now you can select state OFF without sun condition and mark small timeintervals of tlp and Check the lamps.

Have you solved your problem and is the timelinepicker with sun events working? What is the reason that it didn’t work?

Hi Torsten,

I didn‘t have time to look at this some more. I‘ll get around to it.

Best,

Thomas

Hi @tose
I updated to V4.1.1 and it finally works!
I’ve done various tests and it seems to be ok.
My question now is… how do I delete a timeline, for example the test one… or an item that I no longer use… example
(2024-04-04 11:08:00.529 [ERROR] [.automation.script.file .RNTs-tlp3.js] - tlp - E002: error in inner loop org.openhab.core.items.ItemNotFoundException: Item 'TermostatIngressoComfort' could not be found in the item registry)

Hi, solved…
I didn’t remember the admin string, to see the timelines, and be able to delete them.

Oh, thats just fine. Sorry i forgot to point you.

But for clarification:

  • Yes, each created timeline can be removed in the admin widget of timelinepicker.
  • When you remove the last timeline, the tlp thing automatically will also removed and OH is clear.

Hi.
Good job!!
Everything works, the only thing things remains in error.

@Domotekhome Fine :+1:

The observed error in Thing status is not really an error. I’m using the Thing to store all nessesary data. The approach is usefull but unfortunally it’s not possible to suppress this ‘error’.

Hi all,

did some more testing. It looks as if the sun related events are not working properly for me. I.E. Sunrise today was at 05.50am (CEST). My sunrise item also holds this time and is linked in the TLP admin page as a DateTime item, zero offset. In my timeline picker I set my item to siwtch on between 04:30am and 07am, with the additional “no sun” option.
Expected behaviour would be that the items switches on at 04:30am and switches off again at 05:50am (sunrise).
Observed behavior is that it switches on at 04:30am and switches off again at 07:00am, so not observing the sun condition at all. Any idea what I am doing wrong?



Screenshot 2024-04-24 085756
Screenshot 2024-04-24 085851

You have misunderstood the switch condition. Your config says: Switch on the item in the time delta of 4:30am to 7.00am if no sun. This is fullfilled at 4.30am. At 7.00am will the item switched off without any condition.

The correct way to setup the timeline is:

  • set one time slot to on with condition: no sun at 4.30am
  • set all following time slots until 7.00am to off with condition: ‘no sun’

So your item will be switched on at 4.30am (condition no sun) and when the the sun is rising in your intervall and the condition ‘no sun’ is fullfilled, the item will switched off. At 7.00am is a static point and the item will switched off.

excellent, thank you for clearing that up. I’ll try with the suggested setup.