TKB TZ06 in-wall relay switches not updating state changes

zwave
Tags: #<Tag:0x00007f0147cf46b8>

(nicco demi) #1

I am using openHAB 2.4.0-M7 on debian 9 linux server with UZB zwave stick.

I have added few TKB TZ06 in-wall dual relay switches and they work as expected (can control them from Habpanel) but they do not update their state if I manually press wall button (until they are polled).

When I press the wall switch controller receives message like below (regardless of which switch I activate)

NODE 5: Got a value event from Z-Wave network, endpoint = 0, command class = COMMAND_CLASS_SWITCH_BINARY, value = 255

It seems that endpoint is set wrong, it should be 2 or 3.

I tried manually setting association group 1: Relay 1+2 to Controller but it makes no difference.

Any help would be appreciated.

Attached are screenshots and debug logs.

node5-reinitialize.log (295.1 KB)
node5-binary2-ON.log (4.9 KB)
node5-binary3-ON.log (4.9 KB)


(Angelos) #2

Can you upload the xml for this node from $OPENHAB_USERDATA/zwave to check it against https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/156

it should be: /var/lib/openhab2/zwave/network_fbbe1ea3__node_5.xml


(nicco demi) #3

@Dim yes, here it is.

network_fbbe1ea3__node_5.xml (11.9 KB)


(Angelos) #4

Not sure why it’s not working. It seems to me that the endpoints are configured correctly.
The only thing that I can see is that the Association Group 1 has no check-mark on the Controller option (to send reports to the Controller)… but you modified that already.

I will update the DB and request a review (anyway, the DB entry is missing some info)

Maybe if @chris has some time he could take a quick look at this


(Angelos) #5

@niccodemi : I updated the DB entry here: https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/156

with all info that I could find and linked all 3 Association Groups to the controller.


(Chris Jackson) #6

By “this” do you mean to review the database and update? Or was there something more specific you wanted me to look at?

The lack of a check in the controller box will definately be an issue. For ZWave plus devices it doesn’t matter as the binding can determine this automatically, but for older devices (such as this seems to be) that is not the case, and associations won’t be configured without this.

Anyway, I will try and look over the database tonight, but it might be tomorrow (this week is busy with work, and every night up to tonight I’m also out :sunglasses:)


(Angelos) #7

not the DB entry: the debug log to see if you can identify the problem. I already updated the DB and can further update it if you find the root-cause :slight_smile:


(Chris Jackson) #8

Ah… I hadn’t read the first message…

I think the bad news here is that it’s not possible to get the endpoint (I recall we checked with the manufacturer for the Philio devices). If I remember correctly for these devices, they can not use multi-channel-association, and do not report their associations using the multi-channel encapsulation. Therefore, all switches will report the same thing from the root endpoint.

There is a standard concept with ZW+ devices that changes the way this works, and some older devices do their own thing to also achieve this, but I don’t think these device support either.


(Angelos) #9

there were several errors in the DB which I corrected for this device entry

The device manual says that it is a ZW+ device with Multi-Channel Command Class support… of course I may have found the wrong manual since it seems that several resellers white-label this old device.

I believe that the next DB export will fix the issue.
Case closed for now, thanx Chris! :+1:


(Chris Jackson) #10

Ok, I was just going by what is in the database. If the device is a ZW+ device, then the binding will detect this and it will work :slight_smile:


(Chris Jackson) #11

Ah - it’s NOT a ZWave Plus device - I just checked the XML file that is attached above. I therefore think that this is a standard device the same as the PAN06, which I think doesn’t support this level of reporting.


(Angelos) #12

:slight_smile: just for me to know for future reference: how do you identify this aspect (ZW+ or not) within the xml? (I am clueless and still learning Z-Wave :stuck_out_tongue:)


(nicco demi) #13

thanks, so that means I can retest with snapshot binding once database is exported?

BTW I was using these kind of devices in the past with Veralite controller and reporting worked without issues.

And also manual states following

manual-extract


(Chris Jackson) #14

Just look in the list of command classes to see if there is one called ZWAVE_PLUS_INFO (or something similar to that).


(Chris Jackson) #15

It doesn’t seem to support multi-channel-association as far as I can tell. Unless you can work out how to configure the reporting, it is clearly not able to use the standard approach from ZWave.