Topic Removed

This post was flagged by the community and is temporarily hidden.

You’re right - it seems the database doesn’t have the parameters added -:

https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/721

You can find information on updating the database here -:

https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-database-guide

Note that once the database is updated, you will need to update to the latest version of the binding.

[Topic no longer relevant]

1 Like

[Topic no longer relevant]

Yes, it did, don’t worry :grinning:

Edit: you made a couple of mistakes regarding the bitmask, give us some time to fix it …

1 Like

Done.
@chris could you please check config parameters #10, #49, #50, #57, #201,
Those deal with multiple word sizes and MSB/LSB and I’m not sure I did everything right. Thx.

Thanks @sihui.

The manual is a little confusing, but I think I agree with what you’ve done in general.

Param 10 - I think I would combine the MSB/LSB part (upper 16 bits) into a single parameter. I guess that this is just the two bytes of one (sub) parameter. What do you think? I can check with Chris Cheng if needed…

I would suggest to remove the #49 lower byte that is just reserved - there’s no point in having this in the database at the moment I think?

For #49 units - I think we can set some options (I’ve added).

For #49 upper 2 bytes, again, we can make this 1 parameter. The example they give shows this - eg 0410hex is 1040 in decimal - they say this is 104 deg. Same for the celsius option - its 400 in decimal which they say is 40C.

#50 is the same as 49…

Something is wrong with #57 as the manual says it’s only 2 bytes, but you have a bitmask of F0000. I think we should have 2 subparameters - bitmask 000F which is the unit, and FF00 which is the temperature.

I think 201 is the same as 57 - the low byte is the unit (so we could use 000F) and the second byte is the temperature offset - FF00).

What do you think? Does that make sense?

Sounds good to me, will finish it up tomorrow morning (or if I have to much beer tonight tomorrow in the afternoon :grinning:)

Thanks - enjoy the beer :slight_smile: .

Done.

Arghh, now I see, I was still in word size 4 mode of operation :sunglasses:

Thx, it turned out I had to be the designated driver (order from wife), so I had no beer at all :rofl:

HAPPY NEW YEAR!

Ooh - that’s harsh :wink:

And to you :slight_smile:

Thanks for the update - I’ll do a binding update later to wrap this up.