Tp-link Binding Adding HS103 Please help

Can someone help me to add support for the TP-link Smart Plug HS103. Should be same support as HS105. Just a lower amp plug. I didn’t even know there where multiple mini Smart Plugs.

Switch TP_Humid_Switch "Humidifier" ["Switchable"] {channel="tplinksmarthome:hs105:f51a4ab0:switch"} Number TP_Humid_SSI "Signal [%d dB]" <signal> {channel="tplinksmarthome:hs105:f51a4ab0:rssi"}


Please help.

Install the tplinksmarthome binding that is available in the Eclipse market place in PaperUI (after uninstalling the current tplink binding)

Sweet thanks so much! I add a Call for the HS103 in the Item Channel correct like doing for the HS105?

Yes, hs105 vs hs103. The rest is the same

When I try to add the HS103 via the paper UI when you select manually add TP-link device the HS103 does not show up in the list. I’m not sure if that is a issue or not. I will attempt to add the devices manually via the .Items files tonight and report back if I have issues.


The HS103 items still seem to not be working. I uninstalled the TP-Link Binding. Rebooted the OH. Re-Installed the TP-Link Binding. (Located in OpenHab Addons Binding.

This is my .items File

   Switch  TP_Office_Switch  "Office Light" ["Switchable"] {channel="tplinksmarthome:hs103:b3b14794:switch"}
Number  TP_Office_SSI    "Signal [%d dB]" <signal> 	{channel="tplinksmarthome:hs103:b3b14794:rssi"}

This is my Sitemap Code . sitemap

> Switch item=TP_Office_Switch label="Office Light" icon="poweroutlet"
> Text item=TP_Office_SSI label="Signal [%d dB]"  icon="network"

In PaperUI the devices show ONLINE.
I linked the Channel to the switch item.

However when I ask google to turn on the Office light it says it’s not setup.

Any thoughts on the issues.

If you re-installed the TP-Link binding from Add-ons, then all you’ve done is to remove it and add back the same binding, which doesn’t support the HS103. Per Hilbrand’s earlier post, you need the beta binding from Eclipse:

  1. Uninstall TP-Link Smart Home Binding 2.4 (Paper-UI > Add-Ons > Bindings)
  2. Install Eclipse IoT Marketplace (Paper-UI > Add-Ons > Misc)
  3. Install TP-Link Smart Home Binding (Beta). This only shows up after you install Eclipse. (Paper-UI > Add-Ons > Bindings)

If you do that, I think your HS103 should be discovered and show up in your inbox. I also had trouble figuring out the Eclipse IoT Marketplace at first.

Ah that makes more sense. Thanks for the help still new to Openhab getting better with it but still got lots to learn. Thanks for a little more detailed explanation.

To the developers Thank you for getting the HS103’s working. Just a FYI they dont seem to respond to the RSSI channel for the Signal Strength.

No worries. The folks here are really helpful, but sometimes short on detail. I get that, though. When you’re an expert in something, it’s easy to skip over the steps that might trip up beginners.

I also imagine that the veterans don’t want to spend all of their time repeating the same things over and over for beginners. I know I’d get tired of it. Hopefully those of us who are newer can help each other out, so that the Hilbrand and others can keep developing cool new features for us to use!

I only got started with OpenHAB last week, so I’m also figuring this stuff out. I basically just read any post that seemed relevant to an issue I was having, then tinkered until it all started to make sense.

Good luck!

Thanks again for the information. Although your message is 9 months old, it is still relevant. As soon as I removed the old TP-Link binding and installed the beta version, my HS103 smart plugs were discovered and placed in the inbox. Now I just have to figure out what to do with them.

Welcome, John!

I think it’s best to start by adding your items and configuring your sitemap via text files, which you can do as soon as you’ve added your switches in PaperUI. In my opinion, that makes it easier to build rules.

Here are some examples of how I use switches and plugs in rules:

  • My main lights will always turn on my mantel lights.
  • The counter lights in my kitchen will always turn on an hour before sunset, but only if my main lights are on.
  • In the summer, I connect my air conditioner and bedroom fan to smart plugs so that I can turn them on/off remotely and with Google Home.
  • My laundry room light turns off after five minutes.
  • If my “Away Mode” virtual switch is on and it’s after dark, my lights will turn on when I unlock my door (I really love this one).
  • If my “Nighttime Mode” virtual switch is on and I walk past my motion sensor, the kitchen lights turn on at 30%.
  • When the alarm on my phone goes off in the morning, my bedside light turns on.

Good luck!