Tradfri color bulb with zigbee controller does not restore brightness


(Renier) #1

Does anyone has the same issue, that the tradfri color bulb are always full brightness when turning on.

Without a gateway directly connected with zigbee binding.


(Chris) #2

Maybe I´m missunderstaning your question.
But from what I remember:
The on / off toggle in OH set the dimming-level to either 0 or 100. Without a rule you need to write yourself, the last value you set (maybe 40% brightness) will get lost.

Best regards
Chris


(Christian) #3

For me the brightness seems to be no issue. It will get restored to the previous value. But it does not Work for color settings. I have a tradfri bulb with zigbee Binding running. By the way, I am using 2.5.0 M1.

Does anybody know how auch a rule would look like? I have the problem that the bulb is powered by the main switch. So it should be offline and I thought I can trigger on the device coming online again but the zigbee Binding shows the bulb as always online. Any ideas? Thanks!

Br, Christian


(Renier) #4

No rule is needed it’s a buildin feature of the zigbee binding.
After installing the latest snapshot of the zigbee binding all lights, also color is restored correctly.
This was a bug in the binding.


(Christian) #5

That’s what I also can observe. But what I want to achieve is e.g. dimming the lights automatically if I will get up in the morning. I can imagine a rule which triggers on the device which comes online by switching on the mains and checking a certain time slot. But I do not know what’s a good way to get this working. Do you have any idea?