Tradfri - Host overwritten by IPV6 address

Since a few days my tradfri configuration in openhab is automatically overwritten.
The host is overwritten by an IPV6 address, but IPV6 is not in used on my network.

How can I prevent this overwrite and why does it happen?

Are you sure that IPV6 is not used in your network resp. especially on your OH instance ?
What does the ifconfig command show for your network interface ?
I would assume an IPv4 and IPv6 address ?

May be How to disable IPv6 on Linux - TechRepublic helps. I have no clue about the effects for ( all ) the other bindinds you have in use.

Unless something changed by itself, there is no device that I can configure, where ipv6 is enabled.
Leave alone getting an ip adress.

Hey everyone,

I’ve had the same issue and I believe I found a workaround, at least. Every one or two days at least, sometimes several times a day, the thing configuration of the bridge would change on its own from the correct hostname or in my case ipv4-address to an ipv6-address. I’ve now completely disabled ipv6 in my home network (including the ULA option) and blocked the Tradfri gateway’s access to the internet. I don’t know if that second step is necessary, but I read that even if your router doesn’t supply ipv6-addresses, devices that connect to ipv6 services online, might still obtain an ipv6-address from there.

It took about a day to take effect (due to the lease time, I suspect) but meanwhile, it’s been running nicely for almost a week.

For the sake of completeness, before that I tried the following without success:

  • disable ipv6-support on the openhabian system (Openhabian on a Raspberry Pi 3 B+), as in the above link Wolfgang_S posted
  • delete the bridge item and add it as an .item file. While adding the bridge in itself worked nicely, it didn’t solve the problem and then I had an non editable item, so I couldn’t even (re)set the correct ipv4-address in the UI anmyore.
  • bought another gateway at IKEA because they are not that expensive. Same issue. At least I have a spare now…
  • disable the option “use ipv6” under “settings-> network” in the UI

So, none ob the above had any effect, until completely disabling ipv6-support. Incidentally this also solved or at least mitigated some issues with some other hardware and other bindings, including Homematic. It seems the world is not quite ready for ipv6-devices yet :wink:

Anyway, I’m aware that disabling ipv6 completely may not be an option for everyone but I hope it helps someone, at least. Personally, I’d like to understand why the Tradfri binding is able to overwrite custom configurations made by the user, even via .item files. Maybe the above info also helps the developer understand the issue.

1 Like

I have this problem from time to time as well.

I set ipv4 address to Tradfri bridge and it works well. But eventually it goes offline, and when I check properties I find, that the address field has ipv6 address.

I disabled ipv6 on debian, disabled ipv6 on router, and switched off ipv6 on openhab, but from time to time this reoccurs.

@HansWurst HansWurst, did you resolve your situation permanently?

Hi,

Well, I believe it works permanently. I’ve had two issues since my original post. A few weeks ago, my router had issued an ipv6 address due to a software update that reset some of my configuration. After resetting everything to ipv4 only, it worked again without a hiccup. Then, last week the tradfri bridge thing was offline despite the correct config. I had to physically unplug it and let it restart. I have no idea what the issue was, but I think it was unrelated to the original problem.

So, apart from those two instances everything’s been working nicely for quite a while now. Personally, I don’t miss ipv6 support in my home network but maybe that’s not true for everybody.

1 Like