Transition From OH1 to 2

I have upgraded my OH 1x to 2. Now I am trying to use iOS app. In URL I tried


Error 500
and for

request failed unacceptable content type text/html

Appreciate any help

That’s how my local URL is configured. It works just fine.

Try restarting the iOS app? Periodically I need to do that.

Otherwise, what do your logs say when you open the iOS app? Perhaps there’s something incorrectly configured in your sitemap file.

Many restarts, reinstall
I get Internal error 500 in app, openhab.log has no errror

What’s your default sitemap? Make sure the file name and the site map tag both are the same. Then go to the iOS app settings, select sitemap, and make sure it’s selected.

A search of the forum shows other people are experiencing error 500 over sitemap issues so I suspect your problem might be there.

I have only one sitemap and items. both are named as myhome.sitemap and myhome.items

sitemap myhome label=“My_Home”

I selected My_Home… same error

It might have just been a typo, but make sure you use a closed curly brace after your frame.

You could always try the demo sitemap, just to rule out sitemap issues.

Does your sitemap load properly in basicui from a browser with no errors in the log? Newer versions of openHAB are more strict than older ones in handling minor syntax errors.

Are you sure your router isn’t blocking the port? And that the phone is connected to the right network? I once spent an hour troubleshoot the iOS app before I realized I had wifi turned off, so don’t be offended by my asking.

I am able to view sitemap from desktop browser. only iOS app shows error

Appreciate if you could help

Did you try the rest of the things I suggested? You didn’t say so whether you did or not. I would try getting the demo sitemap working first to ensure it’s not network related.

.My Bad. Demo site comes up clean. rest api comes up clean. only custom sitemap throwing 500 error

I am able to fix the issue.
Map transformation was having issue. Map transformation should be %s not %d. One of mine had %d. took a while.
If you are having issues with iOS app not displaying sitemap
Please check http://hostname:port/rest/items/ in your browser. If you get complete list of items in rest format then iOS app will display sitemap, if not disable map transformation, check logs

I’m glad you got it working. It’s amazing sometimes how a small typo like that can cause big problems.

Do you use eclipse designer? I don’t use it for most of my coding, but the syntax highlighting can be useful in diagnosing problems like this.

Yes I use eclipse designer.