Trouble including Qubino Flush Dimmer Plus

I recently bought 2 Qubino Flush Dimmer Plus devices and just installed one of them behind a regular light switch but I’m now having trouble including it with Openhab 2 using Habmin2.

According to the manual when the device has power attached it should go into inclusion mode but with openhab in discovery mode it never finds anything.

I’ve also tried this directly on my Zstick (detached from the computer hosting openhab) but it still does not work.

At one point I managed to get some kind of connection because a node.xml file was created for it, but no “thing” was found in habmin or paperui.

I tried completely resetting my openhab install (wanted to do this anyway as things were getting cluttered and broken form messing around with stuff) but now I can’t even get this far anymore though I can add my only other zwave device again without problem.

I’m hoping someone can help with this, not sure it’s even an openhab issue or if I’ve just installed the device wrong or something…

Update: I think there may have been something wrong with the module I was using… I removed the device and installed the second one I bought - this one I was able to add to openhab but it shows up as an unknown device.

The node.xml file was generated properly and it’s the same manufacturer code, deviceType and deviceID as in the zwave db at: ZMNHDD

I also excluded and added my swipe device back just to check my openhab install was definitely ok and though it was discovered properly, it’s also showing up as an unknown device.

Is there a bug in the current version of habmin/zwave @chris?

There’s a bug in ESH/OH2 that I believe is causing this -:

Well that would explain it… is there anywhere to get an older version of openhab from before the bug was introduced?

The bug has always been there - it’s not new. The issue is that it depends on a number of things as to wether or not it causes the “unknown device” issue so you might get lucky and it might work, or not…

Ah OK… so what seems to trigger it? I mean, does it happen on a device by device basis where one might work and one might not? Or could my unknown devices start working between reboots? Or would it take a complete reinstall to have the chance for it to work…

Yes - they could start working between reboots…

The issue is that at different times, different information is available, and currently there’s no easy way to consolidate this. In theory, more information is available later on in the discovery process, but I suspect some devices send messages that get interpretted in a certain way and cause the inbox to be updated. Since there’s no way for the binding to know if the device is already added to the inbox there’s no way to resolve this at the moment.

Did you add the device as a thing, or is this just showing as unknown in the inbox?

I added it as a thing from the inbox where it was showing as unknown so I now have an unknown thing added.

What do the logs show? Anything of use?

Not sure if anything’s of use, I’ve enabled debug logs on zwave so there’s quite a bit in there… can I upload the log file somewhere or email it to you to have a look?

I was wondering if there were any exceptions when accessing the database - I don’t think in general the log will be helpful as clearly the zwave protocol side is working ok as the device is reported correctly.

I guess you’ve refreshed HABmin (just in case it’s cached something)?

Sorry - wrong answer (got mixed up with another thread). Feel free to email me the log if you like…

I had the simular problem with the Qubino flush dimmer PLUS, i use a Zstick (GEN5).
What I did was included the device manualy with the Zstick disconected and pressing the button.
After i connected the Zstick the device showed up as an uknown device in Habmin2´s inbox, then i switched over to paper UI and it sohwed up as a uknown device there as well.
So i deleted it from the inbox several times, and after some tries it suddently showed up as a Flush Dimmer, then i added it from Paper UI and it been working since then.

Using PaperUI or HABmin will make no difference to this issue. The issue is related to the way the binding works, and the way ESH manages the inbox. As above, this might work, or it might not - it depends on the order things run.

I’ve just emailed you the log Chris, let me know if there’s anything else you need.

Thanks. I’ve identified another workaround which I’ll merge later and will hopefully help to work around this problem.

Awesome! Let me know when it’s done and I can test it out :slight_smile:

Are you defining the things manually (ie in a .things file), or through the UI?

Just through the UI

Ok - thanks. I’m not so sure I’ve found anything that will help actually, but I will add some more debug. The problem is that if some properties aren’t set when the inbox entry is generated (due to this ESH issue) then the device doesn’t get discovered correctly. I’ve tried adding workarounds to detect this and update the information, but for some reason it’s not working.