Trouble transitioning to OH2 and ecobee

I am trying to switch to OH2 stable
I have it installed and am using PaperUI

I managed to get the ecobee plugin installed and configured with my API key but I’m stuck there.

I added ecobee.cfg, which looks like it works as a one way configuration (ie it is read on start up as default values)
(Note it seems i don’t need to set the scope to ecobee: )

I added an ecobee.item with only one line
String identifier “identifier [%s]” { ecobee="<[99999999999999#identifier]" }

I then tried to make a default.sitemap with only the identifier but i can’t seem to figure out how to access it.

Here is all I’m getting in the log
[DEBUG] [org.openhab.binding.ecobee ] - BundleEvent STARTED - org.openhab.binding.ecobee
[INFO ] [b.core.service.AbstractActiveService] - Ecobee Refresh Service has been started
[INFO ] [inding.ecobee.internal.EcobeeBinding] - No Ecobee in-bindings have been found for selection.
[DEBUG] [inding.ecobee.internal.EcobeeBinding] - Nothing to retrieve for ‘DEFAULT_USER’; skipping thermostat retrieval.

So far I haven’t seen the authorization pin the log, i don’t know if i need to do it again since i had it working in OH1, but I still deleted my java preferences directory and still don’t see it.

I know my OH2 is roughly working b/c i got the chromecast and kodi bindings working though paperUI

If it works like Nest, you need to delete your java preferences and then go to the API website to generate a new Pin and use this new Pin in your config. The Pin is only good for a single use. Once something authenticates with that pin you need to generate a new one.

However, Echobee may work differently if you don’t have to generate a pin on the website itself.

I would go through all of the steps as if you have never had OH connected before and see if that makes a difference.

Hi @rlkoshak, i think it works a little different.
Originally when I got it working with OH1 I generated an API key off the website, then OH generated a pin and out out that to the log, I had to put that pin back into the ecobee website.

I also tried generating a new API key from the website and still the same thing.

I think my roadblock is due to the binding not bothering to retrieve anything and possibly skipping authentication all together.

is there a binding/item step I’m missing?
If i got to my inbox, hit + i see ecobee binding. After clicking on it nothing appears at all.

The Echobee binding is a 1.9 version binding. No Things. No Channels. No autodiscovery (i.e. no Inbox). All Items bound to this Item must be created in .items files. PaperUI cannot manage 1.9 binding Items.

I had figured that and already have an ecobee.item file.
in it is just a single string item

I have a site map that is supposed to pick that up that worked in OH1 but it fails.
i’m getting

[ERROR] [ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve item ‘identifier’ for widget org.eclipse.smarthome.model.sitemap.Text

I think I’m missing a basic fundamental step here and i can’t figure it out

So right now my setup is this
ecobee bindng and actions are installed and configured properly
I have an ecobee.item file with

String identifier “identifier [%s]” { ecobee="<[99999999999999#identifier]" }

I have a default.sitemap with

sitemap default label=“Home” {
Frame { Text item=identifier }

When i go the the site map i see the icon and text on teh left but nothing on the right.
the log reads

[INFO ] [inding.ecobee.internal.EcobeeBinding] - No Ecobee in-bindings have been found for selection.
[DEBUG] [inding.ecobee.internal.EcobeeBinding] - Nothing to retrieve for ‘DEFAULT_USER’; skipping thermostat retrieval.
[ERROR] [ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve item ‘identifier’ for widget org.eclipse.smarthome.model.sitemap.Text

Based on the above the problem lies in the Ecobee binding. I don’t use this binding so will be of no further help. You ecobee.items is in the items folder, right?

Yeah it’s in the items folder with the others.

Thanks for trying, hopefully someone else has some insight.

I moved my 1.8.3 config to 2.0 and had no problems with my two Ecobee instances. Please be sure you’re not suffering from the config sync issue, where if you comment out or change a config key in a .cfg file, the old key remains in the real internal config. I’m on mobile now so it’s hard to offer a link. Check with the config commands at the openhab> prompt or someone can offer better advice.

Thanks for all your help guys,
It turns out I had names the file ecobee.item instead of ecobee.items.

Once i actually names it properly the pin appeared in the log as expected

1 Like