Trouble with Git on install

Having the following issue after flashing latest image and following install instructions, multiple times. Any recommendations? Thanks!
SSH log:
login as: openhabian
openhabian@’s password:
Linux openHABianPi 4.9.59-v7+ #1047 SMP Sun Oct 29 12:19:23 GMT 2017 armv7l

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Thu Mar 29 15:47:27 2018 from
Every 2.0s: cat /boot/first-boot.log openHABianPi: Thu Mar 29 15:56:04 2018

2017-11-29_02:37:20_UTC [openHABian] Starting the openHABian initial setup.
2017-11-29_02:37:20_UTC [openHABian] Storing configuration… OK
2017-11-29_02:37:20_UTC [openHABian] Changing default username and password… O
2017-11-29_02:37:21_UTC [openHABian] Setting up Ethernet connection… OK
2017-11-29_02:37:21_UTC [openHABian] Ensuring network connectivity… OK
2017-11-29_02:37:31_UTC [openHABian] Waiting for dpkg/apt to get ready… OK
2018-03-29_14:29:29_UTC [openHABian] Updating repositories and upgrading install
ed packages… OK
2018-03-29_14:34:22_UTC [openHABian] Installing git package… FAILED
2018-03-29_14:34:22_UTC [openHABian] Initial setup exiting with an error!

Power supply that came with the PI was the issue. It is rated at 2.5 amps, well built. Soon as I put a phone charger rated at 2.1 amps and good cable, it got past the problem! Also bought a better flash card, but it worked with the one that came with the PI.

Yup. Make sure you have a relatively good power supply for the pi. I use 5.6V 3A and never had any issue running OH on openhabianpi with Zwave USB, DIY 433mhz transceiver, SSD, as well as other GPIO stuff. All powered through the same power supply. I wired all of the peripherals directly through my DIY regulator. Some of the peripherals are backed with boosters to ensure 5V

Hi I have exactly the same issue.

Using RPi own make charger and tested 3 SD cards (Sandisk, Samsung etc); reimaged three times - each from a fresh download.

So I don’t think power, SD card manufacturer, Download issues apply.

Any help would be useful


If you ssh into the PI right as you start the initial boot after flashing the latest Openhab2 an image, how far does it get?

Thanks for the interest

It gets to
“Installing git package… FAILED” then
“initial setup exiting with an error!”

If I reconnect (using PuTTy) then I get to the user/password section - using defaults - I get “Acess Denied”
This continues using ssh until I reburn the SD card.

Possibly one of the most frustrating (next to VW’s weird Morton Codes) things I’ve come across

Have you tried a good phone charger as the power supply? That really all that is left after all you tried.

Thanks for the input but if the branded Raspberry Pi charger is not sufficient then it looks like its a lost cause.

Although I noticed that others have the same problem on RPi that have been in service for some time - so that sort of excludes chargers IMHO.

Looks like I need to keep looking


hatd today the same problem, changing the sd card (used one which works in another Raspi perfect sind month. Change the power supply, now it works, interesting thing the old one was a brand new raspi power supply :-((((