Troubleshooting guide for what to do in case of a dead node

I’ve been happily running along with the zwave for almost a year without mishap. Then yesterday I had to do some electrical work and I shut down the power to one of my zwave outlets. Now this outlet shows up as DEAD in the logs and in habmin.

This posting is not a plea for help figuring out how to get the node back (though any advice on that front would be appreciated). But after it happened I searched around and I could not find any posting in this or the old forum nor is there any information in the wiki that tells me what I should do in this situation.

So, step by step, what should one do when one of their nodes shows up dead? There might be two version of these instructions as sometimes I’ve had nodes show up dead but still respond to commands and another for it showing up dead and not responding to commands.

I will add a section to the wiki once I’m told what someone should do in this circumstance.



I didn’t get any response so I guessed and blundered my way through. Here is the process I followed to deal with the DEAD node. I’d love to hear if this is a reasonable approach (@chris?) . If it is I’d like to add a section to the wiki.

If one encounters a persistently DEAD node with error messages in the log “Node is DEAD. Dropping message.” and there is no data being received from the node and/or the node does not respond to commands. An important log message to look for is “Is currently marked as failed by the controller!” as this means the zwave controller itself thinks it is dead, not just the zwave binding, which is required to remove the DEAD node from the network using the instructions below.

The steps to follow are:
0. First try to heal the network inside habmin

  1. Remove the zwave device from the network using the instructions for your dongle and your device (don’t know if this is required)
  2. Include the failed device back into the network using the instructions for your dongle and your device
  3. In habmin2 (I could not find a delete button in habmin) select the dead node and delete it from the network
  4. Restart the zwave binding (restart OH, touch the zwave binding’s jar file, etc). NOTE: the node will not disappear until the binding has been restarted
  5. Make note of the new Node ID number for your failed device by watching the OH logs or the device list in habmin
  6. Update your Items to use the new node

I welcome any and all comments, corrections, and suggestions.

Hi Rich, thanks for the post.

I have a failed node, but I don’t appear to be able to exclude it.

I’ve tried to reinitialise and heal both the node and the network. still no joy though.

And there is no node17 xml file.

nodes 5,10,12,24 seem to be working ok, although 5 can be a little flaky at times.


Hi Rich,

I tried to do along your description … I there is no effekt … my case is a little bit different. I see a node in grey in habmin, no idea what it is (I included a silverspring plug which needs several trries and after a binding reload it was there. No idea what node 9 is?

Is it possible only to delete the corresponding xml file …

many thx in advance


A couple of things to note. You can only delete a node if the controller (i.e. the zwave dongle) thinks it is dead. Secondly, the zwave binding will just recreate the XML file if the node is still in the list of nodes on the Dongle.

It is the zwave controller itself that actually knows about all the nodes and how they communicate. The binding is somewhat limited in what it can do.

hi thx after a second reboot it works the node is disappeared.Perhpas you cann help me with another issue. I inserted a everspring AN147 wallplug. It has a button to switch on/off power. I wannted to switch on /off a lamp. I’m looking for a item entry for it.
I could only find items files measuring watt / power for example …
Switch Wall_Plug “Wall Plug” { zwave=“3:command=switch_binary”}
Number Wall_Plug_Power “Wall Plug - current energy [%.1f W]” { zwave=“3:command=sensor_multilevel”}
Number Wall_Plug_Energy “Wall Plug - total energy [%.2f KWh]” { zwave=“3:command=meter” }

What I want to do is simply to to switch on / off a connected lamp …like you can do it with the red button manually.

Many thx

That is a switch for turning the outlet on and off. That is all you need to do.


its an AN147, I saw your item config … I think I have a problem with my item file.
This is my sitemap-file
sitemap Haus label=“Hauptmenue”
Frame {
Group item=uebFT label=“Übersicht Fenster” icon=“house”
Group item=uebPWR label=“Übersicht Steckdosen” icon=“switch”
This my item file
// Gruppen
Group uebFT // Uebersicht Zustand alle Fenster/Tuer-Sensoren)
Group uebPWR // Uebersicht Zustand alle Steckdosen)

Switch Fenster_OG_Toilette " Fenster_OG_Toilette" (uebFT)
Switch Fenster_EG_Toilette " Fenster_EG_Toilette" (uebFT)

Switch Steckdose_Gang_unten “Steckdose Gang unten” (uebPWR)
Contact Fenster_OG_Toilette “Fenster OG Toilette: [%s]”
(uebFT) { zwave=“2:command=SENSOR_BINARY,respond_to_basic=TRUE” }Number
Batterie_Fenster_OG_Toilette “Batterie: [%s %%]” (uebFT) {
zwave=“2:command=BATTERY” } Contact Fenster_EG_Toilette
“Fenster EG Toilette: [%s]” (uebFT) {
zwave=“3:command=SENSOR_BINARY,respond_to_basic=TRUE” }Number
Batterie_Fenster_EG_Toilette “Batterie: [%s %%]” (uebFT) {
zwave=“3:command=BATTERY” }
/Steckdosen/ Switch Steckdose_Gang_unten “Steckdose Gang unten:” (uebPWR) {zwave=“4:command=switch_binary”}

I see my menu of the sitemap file but if klick on it I only see an empty web page?

Klicking on for example Uebersicht Fenster next page ist empty. In habmin I see the sitemap but not the item.file)

I see

In Habmin I only see the sidemap file not the item files, but all sensor in Habmin are green and aktiv.

Any ideas? Many thx in advance

Well, like I said above, I really don’t know much about how to troubleshoot zwave devices. At this point I only know how to do what I described above to remove a dead node. And I’m not even sure I did that right. I can’t help with your problem.

Yesterday after a reboot I got the same message for one battery zwave sensor

NODE 6: Is currently marked as failed by the controller!

It was not responding to any commands and nothing was logged in the logs. Healing the node did not change anything.
I just had to delete the node in habmin, do a scan for new nodes, re-add it and wake up the node.
I am using the 2.2 stable release

This is just in case it helps someone although I am sure Rich’s procedure will also work (although it takes more time)