TTS Notification Sound Volume issues

After upgrading to openHAB 2.3.0 I got an issue so that whenever I used the TTS service to within a DSL rule by using the say() command, the text was spoken and the speakers returned to play whatever music they were playing but VERY LOUD for a fraction of a second. After that they continued with normal volume.

I found out in Paper UI that the “Notification Sound Volume” field was empty. I entered “40” in that field and after doing that the above issue seemed to disappear.

The only problem now is that the Notification Sound Volume is always the same, even if I try to override the default Notification Sound Volume by providing an argument to the say() function like this:

rule "Button_Box_Sw_4 ON"
	Item Button_Box_Sw_4 changed from CLOSED to OPEN
		say("Nu ska vi se", "pollytts:Astrid", "sonos:One:RINCON_78XXXXX400", (new PercentType(40))) // Kitchen Left

It doesn’t matter if I specify 40, 10 or 90, it will be announced using the one and same volume. I noticed that the VoiceManager API doesn’t mention anything about a Notification Sound Volume. It might not be implemented yet, I have no clue.

Any ideas what’s wrong preventing me to specifically select the desired Notification Sound Volume for a TTS Notification?


My experience is a little bit different, since if I put the new volume parameter in say() or playSound(), no notification is heard.
Not having the NotificationVolume channel anymore, the only way to set this volume is, for me, in the Thing (Sonos) in Paper UI, but that will leave with a fixed volume.
This is a pity since before I had it adaptable automatically via rule to the ambient noise and day/night time.
I guess there is something tricky in the audio department.

Update to my post:
I reinstalled Openhab 2.3 from ground. (Before I upgraded).
Now I do can set the attribute for the notification sound, but only as e.g. “new PercentType(30)”. Have to remove the setting in the Thing thou. Using a variable instead of the number works as well.
Still problems are:

  • I am not able to address the sound to a specific speaker
  • the notification volume influences the music volume just 1 sec before and after the message. This is annoying since the music gets suddenly way too loud. Does not happen always.

Same as here then. Notification sound volume works but with issues. Anyway, the feature isn’t supported by openHAB as @vzorglub suggests. Let’s hope someone is working on to implement it because it would be very useful to be able to specify TTS Notification sound Volume.

Similar topic is here: Problem with Sonos notification sound
I’ve put there some workaround.

@RRoe Have a look here

You are right. The linked JavaDoc states latest stable version of the ESH framework which is 0.9.0. OH2 currently uses ESH 0.10.0-SNAPSHOT.