Turn Off Debugging?

I turned on the zwave debugging previously in trying to troubleshoot some issues recently, and Chis is amazing for for his help and patience with everything.

But how to turn off debugging? I have stopped and restarted OH2, and each time, it continues with all of the Debug entries.

Hello Paul,

Here is a link to the openHAB2 documentation that explains logging levels and how to set them: openHAB logging.

1 Like


Thanks Russell. So just to confirm, you basically set the logging level back to INFO?

Also, is there any way to access the Karaf Console when OH2 is already running as a service? It seems having to stop OH2, then restart it manually to access the Console to enable logging seems counterproductive.

You then may often be stopping OH2 again after setting the DEBUG logging to only restart as a service

Yes, that is correct.

I don’t run OH2 as a service so I can’t answer your question about using the console.

You can ssh into the karaf console on port 8101.

ssh localhost -p 8101

Alternatively, you can run

/opt/openhab/runtime/karaf/bin/client "log:set INFO org.openhab.binding.zwave"

replacing /opt/openhab/runtime/karaf/bin/client with wherever you have OH2 installed.

1 Like

Thanks guys.

One last possible question. I tried DEBUG logging the Hue binding with the "“log:set DEBUG org.openhab.binding.hue” but got nothing in my logs.

Is that correct?

Try log:set DEBUG org.eclipse.smarthome.binding.hue