Turning off/on vents of MAX! devices with OpenHab 2.4 and Homegear

Tags: #<Tag:0x00007f7454515048> #<Tag:0x00007f7454514f08> #<Tag:0x00007f7454514e18>

Hi,

I’m using OpenHab 2 together with Homegear to control my MAX! devices via CUL, as there is no working MAXCUL Binding for OpenHab 2.

This setup was working fine so far. I was using a simple hysteresis for controlling the heater. To turn off/on the radiator vents, I used the values 4.5 and 30.5 as parameter for the SendCommand instruction. But I updated the system a few days ago and this values are no longer accepted by Homegear (I guess it is Homegear).

Can anyone please tell me how to set the MAX! radiator thermostats to “ON” or “OFF”?

Greetings
m0nKeY

I don’t know the cul binding, but on and off temperature is equal to setting to the min and max temperature. From memory this is 4.5 and 32°C

Thank you for your reply. It was liks this in past, 4.5°C for “OFF” and 30.5°C for “ON”, but unfortunately this has been changed. Could be the Homeatic Binding or Homegear. I can’t find any documentation about it.

I think I found the solution. I use a MAX!Cube, which is flashed with culfw. Homegear is my bridge between OH2 and the device.

When I tried to change the temperature (from 5.0°C to 4.5°C, it din’t work. Instead it went back to 5.0°C:

2019-10-16 21:50:33.257 [ome.event.ItemCommandEvent] - Item 'wr_set' received command 4.5
2019-10-16 21:50:33.261 [nt.ItemStatePredictedEvent] - wr_set predicted to become 4.5
2019-10-16 21:50:33.263 [vent.ItemStateChangedEvent] - wr_set changed from 5.00 to 4.5
2019-10-16 21:50:34.504 [vent.ItemStateChangedEvent] - wr_set changed from 4.5 to 5.00

So it seems homegear isn’t accepting the command. I Googled around w/o success. Then I searched in the homegear configuration files. This is what I found. In the directory

 /etc/homegear/devices/4

there are XML definitions for the supported MAX! devices. The BC-RT-TRX… are the different types of thermostates:

BC-RT-TRX-CyG-2.xml
BC-RT-TRX-CyG-3.xml
BC-RT-TRX-CyG.xml
BC-RT-TRX-CyN.xml

In these files, look for this section:

<parameter id="SET_TEMPERATURE">
    ...
    <logicalDecimal>
      <minimumValue>5.000000</minimumValue>
      <maximumValue>30.000000</maximumValue>
      <defaultValue>20.000000</defaultValue>
      <specialValues>

This is where the min and max values are defined.
Change from 5.000000 to 4.500000:

<logicalDecimal>
  <minimumValue>4.500000</minimumValue>
  <maximumValue>30.000000</maximumValue>

That is what did the trick. Restart homegear service, and you can switch the MAX! thermostate to OFF!

2019-10-16 21:55:51.081 [ome.event.ItemCommandEvent] - Item 'wr_set' received command 4.5
2019-10-16 21:55:51.087 [nt.ItemStatePredictedEvent] - wr_set predicted to become 4.5
2019-10-16 21:55:51.088 [vent.ItemStateChangedEvent] - wr_set changed from 5.00 to 4.5
2019-10-16 21:55:52.361 [vent.ItemStateChangedEvent] - homematic_HG_BC_RT_TRX_CyG_9d3f5b39_KEQ0406314_1_SET_TEMPERATURE changed from 5.00 °C to 4.50 °C

Now the thermostat display shows “OFF”.

1 Like

Thank you very much, that did the trick. :slight_smile:

Looking at the XML I have seen, that there are special values defined for “ON” and “OFF”.

<parameter id="SET_TEMPERATURE">
    ...
    <logicalDecimal>
        <minimumValue>4.500000</minimumValue>
        <maximumValue>30.500000</maximumValue>
        <defaultValue>20.000000</defaultValue>
        <specialValues>
            <specialValue id="ON">30.500000</specialValue>
            <specialValue id="OFF">4.500000</specialValue>
        </specialValues>
    </logicalDecimal>

Why it is not possible to send the values “ON”/“OFF” via openhab to homegear?

Greetings
m0nKeY