TV Device Type - only power is working in Google Assistant Integration

Hi there, can someone tell me what I am doing wrong or confirm if there is an issue.
I have tried to set up a number of my TVs (power, volume, mute, input) with the Google Assistant integration, but only the power function is detected by google. I have checked, double-checked, and re-checked and can’t find what I have done wrong. I am starting to wonder if the issue is that I have set it up using the openhab UI rather than text-based config.
I have created a group gDownstairsTV, set the metadata to Google Assistant “TV” class and set up the following parameters:

I have added the power (switch type), volume (dimmer type), mute (switch type) and input (string type) to the dDownstairsTV group, but when I update google home it only detects the power function.

Google Assistant works for my other openhab items, including heatpumps set up as the Thermostat class. The issue seems to be with my TV setup.
What am I doing wrong, and also, is there any way I can get a snapshot of my config for you (other than pictures)?


It’s the tv. It probably doesn’t support those functions.
I have a Samsung from 2016 and the only function it supports is shutting down apparently.
The binding is nicely done and uses wake on lan to wake the tv up, but the otherwise the tv smart functions are crap.

Hi Pedro,
that’s not it. All of those items work fine in Openhab (I’ve had it a long time). It’s the interface between Google and Openhab that isn’t working.

Oh! So it worked before?? Then try asking google to “sync my devices” and check what it says. Couple days ago lost connection to my server and I also had some troubles.

You can try and set it up with TXT config just to rule that out.

To rule out any mistakes just use the example config

Group  tvGroup { ga="TV" [ volumeDefaultPercentage="20", levelStepSize="10", volumeMaxLevel="100", transportControlSupportedCommands="NEXT,PREVIOUS,PAUSE,RESUME", availableChannels="1=Channel1=NBC,2=Channel2=CBS", availableInputs="hdmi1=xbox:gaming,hdmi2=settopbox", availableApplications: "youtube=YouTube:Tube,netflix=Netflix:Chill" ] }
Switch powerItem       (tvGroup) { ga="tvPower" }
Switch muteItem        (tvGroup) { ga="tvMute" }
Dimmer volumeItem      (tvGroup) { ga="tvVolume" }
String channelItem     (tvGroup) { ga="tvChannel" }
String inputItem       (tvGroup) { ga="tvInput" }
String applicationItem (tvGroup) { ga="tvApplication" }
Player transportItem   (tvGroup) { ga="tvTransport" }

The issue is not TV dependant and should work even without at TV connected to openHAB

Thanks @denominator,
I’ve loaded the text config and fixed the error in it (availableApplications has a colon instead of an equals).
tvGroup shows up in google with the same issue - only power is displayed.

I should also mention, no errors show up in openhab.log either.

Okay, I have a different behaviour today. I reloaded the text config item this morning (without changing it from last night) and it now loads up as a group (the button has an arrow suggesting there are additional settings), but every time I click on in in Google Home it just opens the “Device Settings” page rather than the item itself. Does the same whether I do a short press or a long press.
I’ve also had a play with the Light Group and it doesn’t work when using the UI. It does however work when you use the example text config from the documentation. I’m now working through determining if it is an issue of the setup requiring every type of item (and option).

Removed the item that had been set up using text, then reinstated it, and it has gone back to old (slightly better) behaviour - only power is exposed.
I thought it might be related to the AvailableApplications option, so copied the config from this other thread which reportedly works. Unfortunately it presents itself in exactly the same manner - only power.

As an aside, I was able to get the light group to work by setting the optional colorTemperatureRange. Once I did this it appeared in Google Home. Even after I subsequently deleted the colorTemperatureRange it still works. Point to note; the Openhab GUI doesn’t offer all of the relevant google light classes; only lightBrightness and lightColorTemperature (lightPower and lightColor are missing). I had to add/change the class in the Code tab of the GUI.
And before anyone asks, I am using Openhab version 3.3.0