Ubuntu 16.04.2 LTS openHAB 2

Hello community,

today i wanted to try openHAB 2. After installing java8 i installed openHAB 2 as described in the installation guide. I chose the stable build. Everything went well and after a restart openHAB is running, but i am not able to open portal with http://openhab-device:8080 nor my_ip:8080

I am using Chrome Version 57.0.2987.98 (64-bit).

Hope someone can help :wink:

Is the DNS name of your ubuntu box openhab-device? You might be having dns issues. Try navigating to the ip of your server http://IPHERE:8080.

Hello, we have chosen “openhab-device” as a dummy name at this point of the documentation. On other sites you might see something like “http://your-ip-address-or-dns-name-here:8080

Would something like this snippet from another site be better?

Kibana is a web application that you access through port 5601. All you need to do is point your web browser at the machine where Kibana is running and specify the port number. For example, localhost:5601 or YOURDOMAIN.com:5601.

To confirm that there is something “listening” for requests, you can execute from the command line

netstat -nl4 | fgrep LISTEN

The n argument provides numeric output, l is to include listening sockets (ones that are listening for connections, but aren’t connected yet) and the 4 says to only list IPv4. The | fgrep LISTEN just trims the output to listening sockets.

If openHAB is up and running, ready for connections, you’ll see a line that looks like:

tcp        0      0  *               LISTEN

The means “any” in terms of addresses on your machine (third column), as well as for hosts that connect (fourth column).


Thank you very much! That answer helped me a lot.

I do not know why but the adress showed:

random ip:53. I tried that but it did not work. But Port 8080 worked for me and now i can start with openHAB!

1 Like

Hi have the same problem, should i use the Ip if the computer that running OpenHab2 and then :8080?

IP:8080? Or the IP if the network router?

Of course IP of your computer running openHAB.

1 Like

My ip address is

So I tried in firefox but got “Problem loading page…”

… So I tried…

That is probably your public IP address - you should use the IP address of the box running openHAB

Now I have made a formate of the Hard drive and installed ubuntu again and then Open hab. But have the same problem.

I try to login from some computer in conected to my router with the IP of my open hab computer IP ( but got : cant login