Unable to add Z-Wave devices


I seem to be unable to add any Z-Wave device.

openHAB 2.3.0 Release Build is installed on Ubuntu-server 18.04.
My Z-Wave stick is Aeotec Z-stick Gen5

In openHAB log I can see that the stick is configured and running.

[INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Connecting to serial port ‘/dev/ttyACM0’
[INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Serial port is initialized
[INFO ] [mmandclass.ZWaveSecurityCommandClass] - Update networkKey
[INFO ] [ve.internal.protocol.ZWaveController] - Starting ZWave controller
[INFO ] [ve.internal.protocol.ZWaveController] - ZWave timeout is set to 5000ms. Soft reset is false.
[INFO ] [age.SerialApiGetInitDataMessageClass] - NODE 1: Node found
[INFO ] [age.SerialApiGetInitDataMessageClass] - ZWave Controller using Controller API
[INFO ] [age.SerialApiGetInitDataMessageClass] - ZWave Controller is Primary Controller
[INFO ] [age.SerialApiGetInitDataMessageClass] - ------------Number of Nodes Found Registered to ZWave Controller------------
[INFO ] [age.SerialApiGetInitDataMessageClass] - # Nodes = 1
[INFO ] [age.SerialApiGetInitDataMessageClass] - ----------------------------------------------------------------------------

The devices I’ve tested are a Remotec Scene Master (ZRC-90) and a Fibaro Door/Window Sensor (FGK-10x).
I tried to add them through Paper UI and by following the manual inclusion according to the manual.
openHAB is discovering any Z-Wave device and nothing in the log.

For the rest openHAB is working. I haved already added Hue, Harmony, Astro, Telegram, … And they are working.

Anyone an idea what the issue(s) could be?


Make sure you are putting the controller into inclusion mode


then hit the inclusion button on your device.

That’s what I do.
I go to Inbox. Click on the +. Then on Z-Wave Binding.
It then says Searching for Things. I press the buttons on the device to add it. But openHAB doesn’t find anything.

At the moment I have an Athom Homey and there it was no problem to add a Z-Wave device. But I’d like to replace it with openHAB as this has more options/posibilities.

To be honest, I have never tried an inclusion with PaperUI. I’m using HABmin which was designed to configure and work with Zwave devices.
So I am not sure if you have to go to your Inbox or your Things section to put the controller into inclusion mode … :sunglasses:

I trief in HABmin with the same result.
I go to Configuration - Things. Click on the loop and select Z-Wave Binding.
On the top right a message appears stating that discovery has been started.
I then click on the button to include the device. But nothing is discovered.

For the FGK, you need to press the TMP button quickly three times, the cover must be closed.
For the ZRC, you need to press the L button once.
This has to be done within the 30 seconds the controller is in inclusion mode.

If it still does not work put your zwave binding to DEBUG via karaf console and feed the log through the Log viewer.

Thx. On the ZRC I was pressing the L+R buttons. And I didn’t know the FGK had to be closed.

But both devices have a status of unknown device. With both I get The device is not in the database and The device initialisation is not complete.

EDIT : I had to wait/wake up before it got recognized.

1 Like

It only worked for the Fibaro sensor. The Remotec Scene Master is still an unknown device.
I pressed the W button several times already since yesterday.

What about the L button?

If it does not work check your device type and id and take a look at the zwave database to verify those are included.

I tried with the L-button, but it’s still an unknown device.

The device is in the z-wave database.

In Paper UI it has the following properties:

zwave_class_basic CONTROLLER
zwave_class_generic REMOTE_CONTROLLER
zwave_frequent false
zwave_nodeid 2
zwave_version 0.0
zwave_listening false
zwave_routing false
zwave_beaming true
zwave_class_specific SIMPLE_REMOTE_CONTROLLER

Wherew can I find the UID?

I don’t remember for unknown devices, it is ages ago that I had this problem :sunglasses:
I guess there is no xml file in your /userdata/zwave folder? Otherwise you would find it there …

There is no xml file for it. There are for my other devices.

It should be shown in the inbox:

It not shown in the inbox switch the zwave binding to DEBUG and reinitialize/delete thing and readd the device.
You should then see device type and id in your log.

I tried this yesterday. I removed it and added it again (at least I think I did).
But now it gets descovered as 2 nodes and for both I get the following warning in the log:
2018-07-27 21:32:00.717 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 5: Device discovery could not resolve to a thingType! 7FFFFFFF:7FFFFFFF:7FFFFFFF::0.0

If you have two nodes now I guess you did an exclusion/reinclusion.
Deleting a Thing is as simple as mark it (in PaperUI or HABmin) and hit the delete button. Then put the zwave controller in inclusion mode and it should appear again in your inbox.

But: whatever you are doing your problem seems to be the data from the device does not get to the binding. Most common problem is you either did not wake up the device or the device is not in close range to your controller.

Note that waking the device up is not triggering the sensor. You will need to push a button (once or several times) to wake it up. How to do that can only be found in your device manual.

To remove the additional node you can go to HABmin, mark the node, switch to advanced mode, then you will see a button “Delete node from controller”. There should be a way to do that in PaperUI too.

When I try to remove the node 2 via “Remove device from controller” I get following message “Remove Node 2 failed - node was not found”. The same with node 5. Which are both the Remotec Scene Master.

I don’t have that device so cannot give you any specific information.
But it should work like all other zwave devices: include it, wake it up with the L button under the battery cover. You may need to do that several times because it is a battery device and is asleep most of the time.


means that the controller cannot read the information from the device, so either it is asleep or too far away from the controller.

This means that the controller believes the device is not in the failed nodes list. Either the device is still alive, or you didn’t first move it to the failed node list?

I did a hard reset of the z-wave controller. I only had 3 z-wave devices connected at the moment.
Now I was able to add the Scene Master.

1 Like