Unable to apt-get update while openHab is running

Hi all,

I have been experiencing a weird behaviour: While openHab is running, I can’t update the repos with (sudo apt-get update). It starts fetching data, but when it reaches openHab repo, it stops…

Hit:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Hit:2 http://ftp.debian.org/debian stretch-backports InRelease
Hit:3 http://archive.raspberrypi.org/debian stretch InRelease
Ign:4 http://repos.azulsystems.com/debian stable InRelease
Hit:5 http://repos.azulsystems.com/debian stable Release
0% [1 InRelease gpgv 15.0 kB]

If I’m right it tries to load the openHab repo when it stops like that at 0%. Also, it seems that it blocks everything on my RPi. You can’t start a new session through SSH while this happening, nor you can’t connect to openHab through web. Ctrl+C helps, but it takes a few seconds to realize that.
If I leave it like that, it will do nothing, just wait there. I had certificate errors, thought that cause this, but today I have resolved them. I have stopped openHab and that time I was able to to update and upgrade without a problem (it was also really fast…).
Restarted openHab, now I have the same problem. Anyone experienced something like this?

What I have tried to get rid of this:

  • Solved Debian certificate errors I had
  • Disabled IPv6 (it became a little faster after disabling, but now it stopped working at all. However I don’t think that this can cause this, because I can upgrade while openHab is stopped).


what is the content of your /etc/apt/sources.list.d/openhab2.list file?

any other *.list files in that dir that may be wrong?


deb https://dl.bintray.com/openhab/apt-repo2 testing main

I don’t see any weird list files.

docker.list    nodesource.list  raspi.list
influxdb.list  openhab2.list    zulu-embedded.list

The last one which gets executed ‘repos.azulsystems…’ is the zulu repo.

try to disable both zulu and openhab2 repos
check if apt-get update runs ok without them
then re-able openhab2 and check apt again

Regarding zulu-embedded: they will not be updating it any more so you can remove it

how come you are on the testing repo?
today OH2.4.0M6 was released on that repo by the way

Yes I know that it is released, but it is not yet seen in the packages, nor I was able to update directly (which you supposed in an article).
I’m using testing repo, because I want to get updates faster than the stable, but I don’t want to mess with daily snapshots…

the package is now available and can be installed with:

apt-get install openhab2=2.4.0~M6-1

(apt-get update is understood… i added it in that post)

I had a few keyserver problems, that seemed to cause the issue. After resolving them, it became fast again…