Unable to complete the installation on my iMac

Hi there,

I’m a new developer on openHAB.
I’ve failed to implement openHAB on my Synology DS415 play.
Therefore, I’ve tried to install this on my iMac with JAVA environment such as below:
java version "1.8.0_102"
Java™ SE Runtime Environment (build 1.8.0_102-b14)
Java HotSpot™ 64-Bit Server VM (build 25.102-b14, mixed mode)

However, I got the below error message while I run the command, ./start.sh
/Users/phoenix/developer/openHAB/openhab-2-2/runtime/bin/setenv: line 161: die: command not found
/Users/phoenix/developer/openHAB/openhab-2-2/runtime/bin/setenv: line 181: [: : integer expression expected
/Users/phoenix/developer/openHAB/openhab-2-2/runtime/bin/karaf: line 261: [: : integer expression expected
/Users/phoenix/developer/openHAB/openhab-2-2/runtime/bin/karaf: line 306: [: : integer expression expected
/Users/phoenix/developer/openHAB/openhab-2-2/runtime/bin/karaf: line 497: /Library/Java/JavaVirtualMachines/jdk1.8.0_102,jdk/Contents/Home/bin/java: No such file or directory

Have no idea how those issues come.
Please help me to clear where I’m wrong or miss.

Hello all,

I’ve figure out the reason and solve it. Now, I’m able to show the openHAB simple from the terminal command.

The reason, which I do not understand how this become, is
The java path I post in previous article, shows as,
/Library/Java/JavaVirtualMachines/jdk1.8.0_102,jdk/Contents/Home/bin/java: No such file or directory
It should be /jdk1.8.0_102.jdk instead of /jdk1.8.0_102,jdk

Have no idea how come the path has a , in it.
There for, I edit the file karaf, which locate in openhab-2-2/runtime/bin/.
The line 497,
${KARAF_EXEC} “/Library/Java/JavaVirtualMachines/jdk1.8.0_102.jdk/Contents/Home/bin/java” ${JAVA_OPTS} \

In the end, now, I’m success to start the openHAB.