Unable to create a new sitemap in HABmin2


I’m trying to create a new sitemap, but I’m unable. Have any of you been able to create it? When I press the option from the menu nothing happens.

I’m using Snapshot 0.0.15 and zwave binding 1.7.0.


This isn’t supported. Currently OH2 doesn’t have the means to support sitemap generation, and HABmin2 is trying to use the standard interfaces. Once this is introduced, I’ll add support…

How can I create a sitemap then?

If you’re using OH1, then I’d recommend using HABmin. If you’re using OH2, then the only real option is to use a text editor.

I’m trying to move to OH1 in order to help with the testing as it was requested by @Kai

Where is documented the syntax to create a sitemap? is it the same as in OH1?

Yes - the sitemaps in OH2 are exactly the same as OH1.

I tried with

Switch	mySwitcher	"LR_Switcher"	<socket>	{ zwave="4:0:command=switch_binary,refresh_interval=15" }

that it doesn’t work. Same line works in OH1.

Ok - just to be clear, this isn’t a sitemap definition - it’s an item definition…

However, items should also work exactly the same as OH1 - you just copy the files over from OH1 to OH2.

One point to note is that zwave definitions should use :0 - this should be removed if you’re not using an endpoint…

I got it working. Don’t know why it wasn’t working before. I copied the item line as it is more interesting than the sitemap.

Anyway, it works now.