Unable to install Java11

According to GitHub - openhab/openhab-syno-spk: openHAB Synology SPK Install Package, Openhab 3.0.0 requires Java11.
The Installation guide says that I should edit /etc/profile.
But when I connect using SSH I cannot acces the file. I always get the error message “permission denied”.
Has anyone already installed Java11 on a Synology NAS according to the installation guide?
What do I need to do to get access to /etc/profile?

Did you use a user with root privileges to edit the file ?

I use my Admin account. I was able to create the required folders in /var/packages and to copy the files into the folders. However since I do not know how to edit a file in PowerShell I copied the /etc/profile file to /volume1 to edit it in my explorer. Then I wanted to copy the edited file back to /etc but permission was denied. I then tried to create a new folder and a new file which also was denied.
Do I have to set the root privileges in the user management somewhere?

BTW: I am working on a Windows PC.

You might not have enough privileges when you are logged on as administrator you need to be root.
Did you login via putty/ssh or with any other terminal emulation but by using the ssh protocol ?
After that you need to run

sudo -i

and enter the admin password again.
Now you should be able to copy the file.

Hi Wolfgang
Thank you for your help, I was able to copy the file now.
However, OpenHAB was still not able to run. So I gave up and installed
OpenHAB on a Raspberry Pi that was unused.

1 Like