Unable to Install/Uninstall Add-ons or Channels in Paper UI

I am using openHAB2 and it is working fine except that if now I try to install any new Binding or try to uninstall any of the installed bindings through Paper UI, it is just timing out. I tried exposing items in openHAB Cloud but nothing got saved. When I reopen the openHAB Cloud configuration dialog, it doesn’t list any of the previous selections. I tried adding/removing channels of existing Things but there too the spinner keeps spinning. What has gone wrong?

what hardware you are using? I had similar trouble when i installed it on a RPi Zero. I had to move it to my Pi 3.

Can you check the logs and see if there are any errors getting listed?

I am using Raspberry Pi Model B+.

There is no error in logs but when I try to install a binding in Paper UI,
after a minute or so an error message pops up and then disappears saying
"Error: 504- Gateway time-out".

I am totally stuck as I can’t install any binding from Paper UI.


if it is not showing any errors in logs, i would recommend reinstalling Openhab. This might be due to some permission issues during installation.

You can also try the beta or snapshot distribution as well.

Did you ever figure this out? I’m having the same issue. Thanks.