Unable to install Z-Wave (and other...) binding

Hi all

Have just (re-) installed openHAB2 on my RPi3, and it went well (at least I thought so…).
Tried to install the Network binding just to see if things seemed ok, and it did (again, at leas I thought so…)
Then I wanted to install the Z-Wave binding, and there I slammed into a wall.
After pressing the Install, it never seems to finish, and a look into the log (/var/log/openhab2/openhab.log), and found this:

2017-04-17 19:05:42.616 [WARN ] [url.mvn.internal.AetherBasedResolver] - Error resolving artifact org
.openhab.binding:org.openhab.binding.zwave:jar:2.0.0: [Could not transfer artifact org.openhab.bindin
g:org.openhab.binding.zwave:jar:2.0.0 from/to openhab (https://dl.bintray.com/openhab/mvn/online-repo
/2.0/): GET request of: org/openhab/binding/org.openhab.binding.zwave/2.0.0/org.openhab.binding.zwave
-2.0.0.jar from openhab failed]
java.io.IOException: Error resolving artifact org.openhab.binding:org.openhab.binding.zwave:jar:2.0.0
: [Could not transfer artifact org.openhab.binding:org.openhab.binding.zwave:jar:2.0.0 from/to openha
b (https://dl.bintray.com/openhab/mvn/online-repo/2.0/): GET request of: org/openhab/binding/org.open
hab.binding.zwave/2.0.0/org.openhab.binding.zwave-2.0.0.jar from openhab failed]
        at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:720)[7
        at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:659)[7
        at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:600)[7
        at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:567)[7
        at org.apache.karaf.features.internal.download.impl.MavenDownloadTask.download(MavenDownloadT
        at org.apache.karaf.features.internal.download.impl.AbstractRetryableDownloadTask.run(Abstrac
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)[:1.8.0_65]
        at java.util.concurrent.FutureTask.run(FutureTask.java:266)[:1.8.0_65]
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledT
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPo
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)[:1.8.0_65]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)[:1.8.0_65]
        at java.lang.Thread.run(Thread.java:745)[:1.8.0_65]
Caused by: shaded.org.eclipse.aether.resolution.ArtifactResolutionException: Error resolving artifact
        at shaded.org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:444)
        at shaded.org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifacts(DefaultArtifactResolver.java:246)
        at shaded.org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifact(DefaultArtifactResolver.java:223)
        at shaded.org.eclipse.aether.internal.impl.DefaultRepositorySystem.resolveArtifact(DefaultRepositorySystem.java:294)
        at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:705)[7:org.ops4j.pax.url.mvn:2.5.2]
        ... 12 more

I found the log file, but that’s not to much use since I have no idea how to fix things…

Anything obvious you more experienced people can see?

One thing I might need to tell, is that I had a previous installation of openHAB2 b4, that I uninstalled before I installed a fresh 2.0.0 (at least that was my intention…)

Just tried the Squeezebox binding, and that failed as well…

Was trying to find the correct place to increase the log output, but the file I looked into (from a forum answer here) didn’t have the ‘key’ mentioned in the post.
Where is the log configuration for this kind of stuff?


No one having any hints here?

Direct help regarding exactly this problem if anyone can say based on my input, or help getting the logging to be more verbose would be highly appreciated…


Trying another question then…

When doing ‘sudo apt search openhab2’ on my RPi, I get this response:

Sorting... Färdig
Full Text Search... Färdig
openhab2/stable,now 2.0.0-1 all [installed]

openhab2-addons/stable 2.0.0-1 all

openhab2-addons-legacy/stable 2.0.0-1 all

openhab2-online/now 2.0.0~b5 all [residual-config]

Could the last row, openhab2-online [residual-config] in some way confuse my system when dealing with add-on downloads?

If so, what can I do to remove it? Is there a way for me to know what is part of my 2.0.0 stable install, and what is just old stuff from my previous 2.0.0~b5 install?

I shouldn’t need to do an install of the openhab2-addons/stable, right? I mean, for a network attached RPi my add-ons should be downloaded upon request?


I just had a similar problem. I’ve been working on stabilizing my Z-Wave configuration, and have continued the tutorials, which lays out the installation and use of the Network binding. A short while later, I noticed my Z-Wave configuration was offline, and saw that the Z-Wave binding was now uninstalled, and that the logfile shows it happened at the time I installed the Network binding;

2018-01-19 05:04:11.660 [DEBUG] [org.openhab.binding.zwave           ] - BundleEvent STOPPING - org.openhab.binding.zwave
2018-01-19 05:04:11.661 [DEBUG] [inding.zwave.internal.ZWaveActivator] - ZWave binding stopped.
2018-01-19 05:04:11.662 [DEBUG] [org.openhab.binding.zwave           ] - BundleEvent STOPPED - org.openhab.binding.zwave
2018-01-19 05:04:11.668 [DEBUG] [org.openhab.binding.zwave           ] - BundleEvent UNRESOLVED - org.openhab.binding.zwave
2018-01-19 05:04:11.670 [DEBUG] [org.openhab.binding.zwave           ] - BundleEvent UNINSTALLED - org.openhab.binding.zwave
2018-01-19 05:04:11.677 [INFO ] [core.karaf.internal.FeatureInstaller] - Uninstalled 'openhab-binding-zwave'

Is this the norm, can we not use Z-Wave simultaneously with the Network binding?

I have reinstalled the Z-wave binding and it appears to be settling back to where it was before. Are there known conflicts between bindings that we should look out for (and report when we experience them)?

I am not aware, I use network binding and also zwave and there is no problem with it.

1 Like