Unable to launch openhab due to Java issue


I am trying to instll Openhab 2.2 on my Macbook Pro. However, when trying to launch it via terminal, I get the following:

Launching the openHAB runtime…
Unable to find any JVMs matching version “1.8”.
No Java runtime present, try --request to install.

I have checked my Java installation, and I am running Java 8 Update 144 on the Mac, with standard security settings.

Any clues as to how I get openhab to see the Java installation?


Is the jvm not in a standard location? Do you have a JAVA_HOME environment variable? I’ve never run it on a Mac so I’m not sure what else to check.


Im having the same issue. Have you been able to fix it?

just wanna let you know, I got a trick. I install java SE development kit http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html

Thank you so much for this tip. I’ve been racking my brain for the last 3 hours trying to get this working and this trick did it for me. Huge thanks!

Don’t know if this will help anyone else but I did originally install the Zulu vm and then ended up deleting this and going with oracle which gave me the same result. Then installed the developer files and that worked perfectly.