Unable to setup IDE : Resolution Failed on org.eclipse.equinox.metatype

Hello, I require some help.
Last thursday my IDE (Eclipse) broke.
I removed everything (.m2, .p2, .eclipse, openhab-master folders) and retriggered a complete reinstall via eclipse-installer.
I selected openhab development and openhab-addons v3.
The install process runs normally, once everything is download, I try to resolve app.bndrun and I’m completely stuck here :

Resolution failed. Capabilities satisfying the following requirements could not be found:
    [<<INITIAL>>]
      ⇒ osgi.identity: (osgi.identity=org.eclipse.equinox.metatype)

I tried Maven -> Update project.

Nothing works.
Can somebody give me a hint ?

Did you first update the pom file to add your binding(s) ?

Yes :frowning:

The error about org.eclipse.equinox.metatype in general means there is a problem with building the code. For example an error in the pom.xml. In case of a problem you very likely have an empty list in the left pane of the apprun.bnd file opened in Eclipse. If that pane is empty is an indication something is wrong and trying to resolve at that point will fail with the shown error message.

So I expect you have no errors in eclipse? Do you have Java 11 installed and selected during installation (both for ide and runtime for openHAB?) I just tried a new installation and that worked. But I didn’t clean my maven repository. So it might be a problem there. You can try if you can build the demo pom with maven on the command line.

The left pane is filled (but I also observed that some were followed by a [!], so the issue may not be there. I only have Java 11 installed, and double checked it was fine during the installation.

I did the mvn install -D skipchecks …, and it worked fine.

I’m currently trying once again to reinstall, will keep you posted.

Reinstallation (I think it’s the tenth I did over past days) did it !

Hi , I been struggling with the same problems for days now
Clean eclipse install , clean java 11 VM , latest un-modified pom.xml and I am getting this error in res
resolve app.bndrun failing with the same error .
I tried windows environment and Linux environment , both failed .
Any suggestion what can be wrong ?

Yes, I discovered that I had this error when I updated pom.xml and app.bndrun in launch/app/ instead of org.openhab.demo.app/

1 Like

Strange, I tried many times , clean install , head both on distro and addons and I keep getting this error

I have also cleared my .m2 folder but I think the real solution was to update the correct pom.xml :slight_smile: