Unable to update 2.0 Snapshot using apt (or apt-get)

I have tried up update my OH2-Snapshot. When I run ‘sudo apt update’ get the following errors.

Err:13 https://openhab.ci.cloudbees.com/job/openHAB-Distribution/ws/distributions/openhab-offline/target/apt-repo  Release
   Unknown date format
Err:14 https://openhab.ci.cloudbees.com/job/openHAB-Distribution/ws/distributions/openhab-online/target/apt-repo  Release
   Unknown date format
E: The repository 'https://openhab.ci.cloudbees.com/job/openHAB-Distribution/ws/distributions/openhab-offline/target/apt-repo  Release' does not have a Release file.
E: The repository 'https://openhab.ci.cloudbees.com/job/openHAB-Distribution/ws/distributions/openhab-online/target/apt-repo  Release' does not have a Release file.

I tried running:
wget -S https://openhab.ci.cloudbees.com/job/openHAB-Distribution/ws/distributions/openhab-online/target/apt-repo/Packages.gz

and received the following.

Resolving openhab.ci.cloudbees.com (openhab.ci.cloudbees.com)... 52.20.238.10, 52.71.68.65, 52.2.226.46, ...
Connecting to openhab.ci.cloudbees.com (openhab.ci.cloudbees.com)|52.20.238.10|:443... connected.
HTTP request sent, awaiting response...
  HTTP/1.1 200 OK
  Accept-Ranges: bytes
  Content-Type: application/x-gzip
  Date: Sun, 25 Dec 2016 17:32:27 GMT
  Expires: Sun, 25 Dec 2016 16:57:20 CET
  Last-Modified: Sun, 25 Dec 2016 16:57:20 CET
  Server: Jetty(9.2.z-SNAPSHOT)
  X-Content-Type-Options: nosniff
  Content-Length: 619
  Connection: keep-alive
Length: 619 [application/x-gzip]
Saving to: âPackages.gz.1â

Packages.gz.1                     100%[==============================================================>]     619  --.-KB/s   in 0s

Last-modified header invalid -- time-stamp ignored.
2016-12-25 12:32:27 (1.96 MB/s) - âPackages.gz.1â saved [619/619]

I am wondering if the Last-Modified and Expires headers should be stated in GMT not CET.

It seems like this has been an issue for a while now, I have not been able to update for a week or more.

Glad to hear it is not me.

@Kai - would it be possible for you or another maintainer to look into the “unknown date format” when using “sudo apt update” to update from the Cloudbees server. I think the Last-Modified and Expires headers should be output in GMT and not CET.

I skimmed through the source code for Debian/apt and a comment seems to indicate that dates not specified in GMT will fail and an ultimately return the error “unknown date format”

from: https://github.com/Debian/apt/blob/master/apt-pkg/contrib/strutl.cc

// RFC1123StrToTime - Converts a HTTP1.1 full date strings into a time_t /{{{/
// ---------------------------------------------------------------------
/* tries to parses a full date as specified in RFC7231 §7.1.1.1
with one exception: HTTP/1.1 valid dates need to have GMT as timezone.
As we encounter dates from UTC or with a numeric timezone in other places,
we allow them here to to be able to reuse the method. Either way, a date
must be in UTC or parsing will fail. Previous implementations of this
method used to ignore the timezone and assume always UTC. */

Thanks for your help.