Unattended Install - No Mirror or Amanda

openHABIAN 3 v1.6.4
Main SD card 16gb
Mirror card 64gb (formatted to Fat32)

I am trying get Amanda and Mirroring installed through the unattended install. If I understand the directions correctly, doing it this way will avoid having to change ownership of folders & other Linux terminal tasks.

So here’s what I did:

  • Flashed the sd card with Etcher
  • Opened the openhabian.config file in a text editor, changed debug mode to “maximum”, uncommented “backupdrive=/dev/sda” and save (I also changed the username, password, location, and added my Tailscale key)
  • Inserted the 16gb card into the Pi & the 64gb card into a reader in the Pi’s USB port and let the install run.
  • Went through basic install after it came up, shut it down and pulled the mirror card to mount in in my Linux box & see if the mirror and partitions were there.

The mirror drive had not been set up. No mirror, no partitions. The debug log seemed to refer to the backupdrive path with the # in front of it, even though I had removed that. I checked the openhabian.conf file in rootfs/etc and is still commented out, even though it’s uncommented in the openhabian.conf file in boot.

Logfile attached.

first-boot.log (302.1 KB)

Your external card wasn’t in or isn’t working.

++ blockdev --getsize64 /dev/sda
blockdev: cannot open /dev/sda: No medium found
+ [[ -n '' ]]
+ echo 'FAILED (bad destination)'
FAILED (bad destination)

@mstormi thank you. I’m using a different card reader than I was testing with earlier and didn’t realize it was mounting the card at sdb instead of sda.

OK, getting closer. Mirror works but there are no backups after waiting overnight. I can create a backup in the config tool but it places it in /var/lib/openhab/backups.

Logfile:first-boot.log (340.6 KB)

What “backups” are you talking about. openhab-cli is not Amanda. That creates its zip files in that dir but that is not a “backup” although some people call it that. It’s rather a config export. It’s never started automatically.
That’s something completely different from Amanda backups. Those are created nightly in the storagedir you specified in openhabian.conf.

Yes I assumed that doing them manually was different and going to a different folder, though I thought it was still Amanda.

Anyway, there are no files in the storage directory. That is: /storage in the 3rd partition on the backup sd card.

I am still not sure if you are confusing things. openhab-cli backup will create a single (archive) file.
Amanda won’t, it’ll create multiple files that you cannot just copy somewhere. You have to use the amXXXX tools to create and to restore.
You can manually start a dump as shown in the Amanda README.
There’s a system timer to automatically start that once a night.

[13:31:01] root@devpc:/var/log/amanda# systemctl list-timers
NEXT                          LEFT         LAST                          PASSED       UNIT                         ACTIVATES
Sun 2021-04-11 18:38:09 CEST  5h 7min left Sun 2021-04-11 12:24:07 CEST  1h 6min ago  apt-daily.timer              apt-daily.service
Mon 2021-04-12 00:00:00 CEST  10h left     Sun 2021-04-11 00:00:00 CEST  13h ago      logrotate.timer              logrotate.service
Mon 2021-04-12 00:00:00 CEST  10h left     Sun 2021-04-11 00:00:00 CEST  13h ago      man-db.timer                 man-db.service
Mon 2021-04-12 02:00:42 CEST  12h left     Sun 2021-04-11 10:20:00 CEST  3h 11min ago amandaBackupDB.timer         amandaBackupDB.service
Mon 2021-04-12 05:57:47 CEST  16h left     Sun 2021-04-11 10:20:00 CEST  3h 11min ago firemotd.timer               firemotd.service
Mon 2021-04-12 06:55:18 CEST  17h left     Sun 2021-04-11 10:20:00 CEST  3h 11min ago apt-daily-upgrade.timer      apt-daily-upgrade.service
Mon 2021-04-12 12:39:02 CEST  23h left     Sun 2021-04-11 12:39:02 CEST  52min ago    systemd-tmpfiles-clean.timer systemd-tmpfiles-clean.service
n/a                           n/a          Sun 2021-04-11 13:03:35 CEST  27min ago    amdump-openhab-dir.timer     amdump-openhab-dir.service

8 timers listed.
Pass --all to see loaded but inactive timers, too.
[13:31:07] root@devpc:/var/log/amanda# systemctl start amdump-openhab-dir.service
[13:31:30] root@devpc:/var/log/amanda# sudo -u backup amreport openhab-dir
Hostname: devpc
Org     : openHABian openhab-dir
Config  : openhab-dir
Date    : April 11, 2021

These dumps were to tape openhab-dir-02.
The next 10 tapes Amanda expects to use are: openhab-dir-03, openhab-dir-04, openhab-dir-05, openhab-dir-06, openhab-dir-07, openhab-dir-08, openhab-dir-09, openhab-dir-10, openhab-dir-11, openhab-dir-12.


I had the cards out and was just assuming I would see files in the /storage directory to indicate that Amanda had run overnight.

OK so I connected with Putty, switched to user backup, and tried running some amxxx commands and they are not working:

[05:54:22] backup@bpsopenhabtemplate:~$ amcheck openhab-dir
bash: amcheck: command not found

That’s the 2nd time you “assumed” something that isn’t right. If you try new stuff that you don’t know yet, why do you do stuff that is not documented, then wonder it doesn’t work out ?
amcheck would be available in a standard install so again the reason it is not is that you must have messed with it.
Don’t expect people (me) to help you with that approach, you’re wasting their time.