Unclear why one item works and the other doesn't

Hi folks,

I am trying to configure the google assistant with openhab2 using openhasbian on rasberry pi 4.

The following device works:

Color  Color_Master_Bedroom_Fedras_Lamp
    "Fedra's Lamp" (Room_Master_Bedroom)

The following does not:

Dimmer Kitchen_Light 
    "Kitchen Light" (Room_Kitchen)

I can see both devices in the assistant interface: https://photos.app.goo.gl/yED9eQayX5RwPUAd9

But Fedra’s Lamp works (with either the touch ui or the voice commands) while the kitchen light does not.
Google Photos

Interacting flashes a valid state for a moment before it fails, shows Not Responding at the top and goes back to that null state you see in the screenshot.

I’ve tried deleting all of my openhab authorizations with google, and linking and unlinking my account. I’ve tried syncing my devices too.

I get no log messages in log viewer. openhab cloud gives me no logging or insight into the problem.

I’m getting pretty fed up. I see no reason why one works and not the other. As far as I can tell, my next step is to install openhab cloud myself just so I can get a look at the debug logging. It would be super helpful if openhab cloud share logging of it’s interactions with the google assistant.

Have a look in your openHAB events.log, see if you can spot different behaviour there.

No meaningful difference in events.log. The assistant events don’t show up.

Weirdly enough the light started working today. I changed nothing, I was just unable to hack on things yesterday.

So not working for days, 2 days later it starts working after changing nothing. That seems really strange.