Unexpected behaviour of meter report of zwave wall plug Fibaro FGWP101

I started recently using my Fibaro wall plugs FGWP101 in openHAB 2. After setting up the things and having the association group 3 assigned to the node 1, I set up the item file:

Number Flur_LEDLeiste_SensorPower "Flur LED Leiste [%.1f W]"  <energy> (Flur) { channel="zwave:device:a33c3a66:node17:sensor_power"}
Number Flur_LEDLeiste_Energy  "Flur LED Leiste [%.2f KWh]"  <energy> (Flur) { channel="zwave:device:a33c3a66:node17:meter_kwh" }
Number Flur_LEDLeiste_Power "Flur LED Leiste [%.1f W]"  <energy> (Flur) { channel="zwave:device:a33c3a66:node17:meter_watts"}

Based on the XML-file from github “fibaro_fgwp101_0_0.xml”

 <channel id="sensor_power" typeId="sensor_power">
        <label>Sensor (power)</label>
          <property name="binding:*:DecimalType">SENSOR_MULTILEVEL;type=POWER</property>
      <channel id="meter_kwh" typeId="meter_kwh">
        <label>Electric meter (kWh)</label>
          <property name="binding:*:DecimalType">METER;type=E_KWh</property>
      <channel id="meter_watts" typeId="meter_watts">
        <label>Electric meter (watts)</label>
          <property name="binding:*:DecimalType">METER;type=E_W</property>

I would have had expected, that “meter_watts” gets the current power in “Watt” as soon as there is a change > 15% on it. But indeed this one only changes, when explicitely refreshing via Habmin. What I get updated is the “sensor_power” when the current power changes > 15%.

Is this normal, or should I also geht the meter_watts updated by the wall plug?

i also have an issue with metering reports that should trigger at 15% change…but in OH2 in never does with my FGWP101…in OH1 all works. I already set the association group 1+2 to the serial controller.

@chris : Any idea why this now in OH2 does not work anymore. the 30min polling information is received…

Thanks Norbert

This can’t be related to OH2 if the device is not sending the data - it would be the device configuration. If the device is sending data, but the binding isn’t processing it, then maybe there’s something wrong with the database configuration.

I can’t really comment which one of these is happening, but it’s likely the device configuration if the binding is processing the polling messages every 30 minutes. Only the logs can tell though…

hm…Chris thanks for your food for thought…

This means i would have to “get evidence” that really the node 48 (one of the fibaros) does not send values when e.g. the power changes…

I did it in DEBUG…and voila…sensor is sending values…Can you think of any reason why ONLY the 30mins polling messages are updated in the GUI but immediate information is skipped?
Below 2 messages in between plugging in and out the notebook supply…immediate reaction like before in OH1. I also remember that before flashing evertything from OH2.1 that it worked before in OH2+…but here with snapshot no chance…i once did try to go back to 2.1 but this did not fix the situation. Also, good to mention, some other nodes from other brands do react to the GUI when values change frequent (not pulled).

2017-10-01 11:35:58.670 [DEBUG] [ssage.ApplicationCommandMessageClass] - NODE 48: Application Command Request (ALIVE:DONE)
2017-10-01 11:35:58.671 [DEBUG] [alization.ZWaveNodeInitStageAdvancer] - NODE 48: Starting initialisation from DONE
2017-10-01 11:35:58.672 [DEBUG] [ssage.ApplicationCommandMessageClass] - NODE 48: Incoming command class SENSOR_MULTILEVEL
2017-10-01 11:35:58.673 [DEBUG] [ss.ZWaveMultiLevelSensorCommandClass] - NODE 48: Received COMMAND_CLASS_SENSOR_MULTILEVEL command V2
2017-10-01 11:35:58.674 [DEBUG] [ss.ZWaveMultiLevelSensorCommandClass] - NODE 48: Sensor Multi Level REPORT received
2017-10-01 11:35:58.675 [DEBUG] [ss.ZWaveMultiLevelSensorCommandClass] - NODE 48: Sensor Type = Power(4), Scale = 0
2017-10-01 11:35:58.676 [DEBUG] [ss.ZWaveMultiLevelSensorCommandClass] - NODE 48: Sensor Value = 18.1
2017-10-01 11:35:58.677 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 48: Got an event from Z-Wave network: ZWaveMultiLevelSensorValueEvent
2017-10-01 11:35:58.678 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 48: Got a value event from Z-Wave network, endpoint = 0, command class = SENSOR_MULTILEVEL, value = 18.1
2017-10-01 11:35:58.680 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 48: Updating channel state zwave:device:6f2c15ba:node48:sensor_power to 18.1 [DecimalType]
2017-10-01 11:36:01.669 [DEBUG] [ssage.ApplicationCommandMessageClass] - NODE 48: Application Command Request (ALIVE:DONE)
2017-10-01 11:36:01.670 [DEBUG] [alization.ZWaveNodeInitStageAdvancer] - NODE 48: Starting initialisation from DONE
2017-10-01 11:36:01.672 [DEBUG] [ssage.ApplicationCommandMessageClass] - NODE 48: Incoming command class SENSOR_MULTILEVEL
2017-10-01 11:36:01.673 [DEBUG] [ss.ZWaveMultiLevelSensorCommandClass] - NODE 48: Received COMMAND_CLASS_SENSOR_MULTILEVEL command V2
2017-10-01 11:36:01.673 [DEBUG] [ss.ZWaveMultiLevelSensorCommandClass] - NODE 48: Sensor Multi Level REPORT received
2017-10-01 11:36:01.674 [DEBUG] [ss.ZWaveMultiLevelSensorCommandClass] - NODE 48: Sensor Type = Power(4), Scale = 0
2017-10-01 11:36:01.675 [DEBUG] [ss.ZWaveMultiLevelSensorCommandClass] - NODE 48: Sensor Value = 27.1
2017-10-01 11:36:01.677 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 48: Got an event from Z-Wave network: ZWaveMultiLevelSensorValueEvent
2017-10-01 11:36:01.677 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 48: Got a value event from Z-Wave network, endpoint = 0, command class = SENSOR_MULTILEVEL, value = 27.1
2017-10-01 11:36:01.679 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 48: Updating channel state zwave:device:6f2c15ba:node48:sensor_power to 27.1 [DecimalType]

Well, yes :wink: . I’m afraid I can’t just guess what might be wrong.

What does the log show? Is this the live data or polling? I guess it’s the ‘live’ data as I don’t see a TX frame.

To me, it looks like it’s working fine and the values are being updated -:

In both cases the data updates the channel, so the UI should update.

(ps, please post logs using the </> button - it makes them loads easier to read :slight_smile: ).

Chris, sorry - maybe i was not clear enough.

The Log shows two updates that came unsolicitated (not polled)…so it is clear that OH is informed as before in OH1 of a power change (you can see the value changing) gut this is not forwarded to the GUI.

Any idea what to do next, what the reason can be?

Not really. I would have said there’s a link between the channel and item missing, but if it works when you see the polling, then I’m not sure. Can you provide a log showing the polling so we can see what’s different?

Hi Chris,
like before - here the link to a openhab.log file that covers several hours.
It definitely will include polling and the frequent reports for Node 48.


Can you please check Node 48.
Side note that may be relevant to consider as well…I have a rule that takes use of the Power values of Node48. These are also not triggered anymore. So its not just GUI but rules as well.

Thanks a lot for checking…

The log below is from the polling. This seems to be updating the same channels as we saw above, so it should work the same…

Sorry Chris, did not get informed about your reply…
Thanks for checking, but what does that mean now…
I see that the logs show zwave-devices replying immediately…so it can only be something wrong in Openhab2 not forwarding to display in UI. hm

I’m not sure - as far as I can see, there’s no difference in the way things work between the polled, and unsolicited updates. In both cases, the binding seems to be sending an update of the same channel… I don’t really see why the UI would treat it any differently either (sorry - that’s not really helping you much, I know).

Hi @chris - still struggling arround with the Fibaro Plug-Device that does not update on PowerLevel Changes anymore (OH1 worked great…even was able to trigger based on short period power-up changes)…now i only see the 30mins polled updates…so no more dynamic anymore.

What i found out today is that if i switch from ON to OFF or from OFF to ON as recently, no power updates…but if i press the REFRESH ITEMS button in HABMIN, immediately i can see updates coming in.
This behavior is gone as soon as I press OFF or ON again…in order to see again immediate changes I have to press REFRESH ITEMS again…

Any idea/help you could give related to your expertise in this area. Many Thanks, Norbert

This will be related to associations not being configured. It’s possible that this device is using the new multi-channel concept - I would suggest to try the version below (note that this is the development version so you’ll need to remove all things and add them again).

Hi Chris, thanks for your thoughts…
I doubt this Fibaro Wall Plug is holding any new channel concept as the switch model is about 2 years old.
Please have a look in your list if you can see any hint about your suspection…

Thanks a lot Norbert

I can only really repeat what I already said - this will be related to associations.

It does - I already checked before I replied last time. Did you see if the new version helps?

Hi Chris, tried to install your test version of zwave binding.
Did as follows: removed snapshot binding via paperUI. added the TEST version in /usr/share…addons
still in karaf i only see the following…any idea what I did wrong so TEST is not able to be selected.

openhab> feature:list |grep zwave
openhab-binding-zwave │ 2.2.0.SNAPSHOT │ │ Uninstalled │ addons-2.2.0-SNAPSHOT │ Z-Wave Binding

One additional question, if this device is using new channel concept - how was this handled in OH1 as with 1.83 the switch reported very fast and frequent based on power changes.

Did you install the serial bundle which is a dependancy?

It used the single instance version of the command class.

yes I did - as this was also discussed in the other threat. :frowning:
This is development path, right?
When is this going to come to snapshot release?

It is strange…sometimes after restart or when pressing refresh in HABMIN it seems to work correctly for a few times/minutes (to update power level) but then again it stops…


I’m not sure - it’s a major breaking change and I was hoping to make some other changes to avoid too much disruption for those that don’t follow the forum very often. It won’t be in the next few weeks anyway…

@chris - as Testversion did not work for me - is there already a release date for your multi-channel concept on zwave. As my Fibare Plug switches right now do not update power level immediately anymore (depending on the change thresholds). Cheers and many thanks, Norbert