UniFi binding beta [3.2.0;3.6.0)

Hi all,

I’m using the unifi binding for quite long time. I’ve created individual SSID for my kids and using Unifi binding in openhab to control it via WLAN enable channel. Works great as an alternative to yelling at them when dinner is ready.

I’ve been runnning into a strange issue lately:
When I re-enable a disabled WLAN via openhab, the SSID is not visible from clients, and they cannot reconnect to it. Surprisingly, the Unifi control interface show these SSID as online.

Disabling and re-enabling these SSID from the controller interface is the only way to properly reactivate it.

I’ve looked into le logs (openhab & unifi) but didn’t found anything that could explain what happen.

If someone has an idea of what could be happening here …

Hi Guillaume,

I have the exact same behaviour here with my UDM SE. I’m on UniFi OS 3.1.16 and openHAB 4.0.3.

Have you figured out the problem or a workaround already? I’m still lost…

Hi Andreas, unfortunately, controlling my Unifi SSID from openhab is is still broken for me at this date.

@hilbrand no ideas for this ?

No way to get infos of the adopted device?

Thing wiredClient UIUdmP   "Unifi Status UDP Pro"    [ cid="192.168.xx.xx", site="default", considerHome=60 ]
Thing wiredClient UIUdmP   "Unifi Status UDP Pro"    [ cid="XX:XX:XX:XX:XX:XX", site="default", considerHome=60 ]
Thing wiredClient UIUdmP   "Unifi Status UDP Pro"    [ cid="Unifi Dream Machine Pro", site="default", considerHome=60 ]

nothing of this will work for me.
Or am i missing something?

Did you configure the controller bridge thing? It’s missing from your example, therefore I don’t know if you didn’t configure it or just didn’t put it in the example.
Otherwise is it possible to create the things via the user interface? If that works, just copy the configuration parameters to file and remove the ui created things. Or otherwise check the logs if there are any hints.

yes i have configurate . For all the other clients the binding is workin as well.
Also the Port de/activating is working for the UniFi switches.
Just no info for the UniFi hardware.

Bridge unifi:controller:home "UniFi Dream Machine Pro" [ host="192.168.XX.XX", port=443, unifios=true, username="XXX", password="XXX", refresh=60 

if i try to add it via UI the items still stay UNDEF

I am experiencing an issue with the binding staying authenticated or something. When the binding first starts up everything works. Then after some amount of time the items just stop responding to commands and it prints this in the log:

15:29:26.816 [WARN ] [ng.unifi.internal.api.UniFiController] - Not Authorized! Please make sure your controller credentials have administrator rights

Disabling and enabling the Unifi Controller (Thing) fixes it for a time but then it eventually breaks again. Any ideas on why it wouldn’t just auto reauthenticate?

1 Like

Same issue here. I’ve migrated from OH 3 to OH 4.1.0(M4), and I see the same warn. The thing remains in orange (UNKNOWN).

I’ve tried changing the user, with a password with 12 characters. The new openhab user is “site admin” for Network. Is there anything else I can do?

@hilbrand any suggestion? I have also a trace log, but I need to share offline.
Is the beta version same as the official one? Perhaps I can remove the beta and use the official, if the features now are the same.

Any difference between “site admin” and “full management” in UniFi config, from binding perspective?

UniFi OS 3.1.16, UDM PRO, Network 8.0.24
UniFi binding (beta) [3.2.0;4.0.0)

The beta is the same as the original at the moment. The binding doesn’t know about different UniFi users. It just uses the api, so I’m not sure if there is a requirement for a specific UniFi user. The message indicates the binding gets a 403 from the UniFi controller. Which suggest it’s to authenticated. Regarding the stopping of the binding after some time. It could be the UniFi started to require to login, and gives a 403. after some time. The binding currently assumes in that case the configuration is not ok and will stop. It could be this needs to be changed, and to keep on trying to connect. But this needs some thought to do it correctly.

1 Like

For your information, the version in the market is not working for me (stays in UNKNOWN state like what I’ve described above), while the “official” version is perfectly working. What I’ve seen using the beta in the trace log is that the binding stays in orange state, but the information arrives to OH from my UDMP. I perfectly see all the data in json format.

You know better than me what are the differences between the versions :slight_smile: but I’m fully available in case you need to test something.

Going to move my UDMP to 3.2.7

Andrea

yes, i have the same problem.

1 Like

Hi, I have connection issues with Unifi (And Protect) where the Unifi binding goes offline 12 times a day and my mobile phone (Apple & Samsung) online status switches are flipping ON/OFF every few minutes after latest UDM upgrade. Power saving on the phones is switched off and both are stationary with plenty signal.
image

My versions are:
OH 4.1.0 with java 17.0.9 running on Proxmox VM.
UDM PRO is running v3.2.7 OS
Networks is 8.0.26
Protect is 2.10.11

Noticed for both network & protect that every 2 hours there is a reconnection, which could maybe indicated a common issue?
image

My issueswith Connection lost after 20min. with latest UDM PRO Protect version 2.10.11 started with same upgrade of the UDM PRO.

Hello

I my poe port enable / mode switching does not work anymore.
I get a power value back for each port but disabling them or enabling does not work anymore.
The item gets switchted back (i guess when it reads the state after trying to change) after a few seconds.

is there anything i can do to fix that?

thank you

I have the same issue. The openhab log shows a not authorized error. Reading data works however. The user I am using has admin rights so permissions should be fine.

2 Likes

Same error after some time of working perfectly.

UniFiController] - Not Authorized! Please make sure your controller credentials have administrator rights

I just installed the “normal” binding and it is working again :wink: