Unrecognized Device: Aeon Labs DSB09104 Home Energy Meter

Hey all. I have this home energy meter device from Aeon labs. openHab finds it but it says it is an ‘Unknown device’ (not in the registry database, etc). It also lists no channels.

I recently upgraded to OH 3.2 and when I did, I decided to wipe and start over. I don’t remember which version I was previously using, probably 3.1 or 3.0. I do remember that this device worked correctly in my previous install.

As you can see from the data below, a heal was done last night. I’ve also done a ‘reinitialize’ on the device to no avail.

Is there some database I need to update? What do I need to configure to get this device working again?


zwave_class_basic BASIC_TYPE_ROUTING_SLAVE
zwave_frequent true
zwave_neighbours 7,8,9,14
zwave_listening false
zwave_version 0.0
zwave_nodeid 13
zwave_lastheal 2022-06-30T09:58:01Z
zwave_routing true
zwave_beaming true
zwave_secure false

openHAB 3.2.0
Aeotec ZWave USB 5th Gen
Aeon Labs DSB09104 - Home Energy Meter (1st Edition)

For giggles, I removed the device from OH, excluded it from the Zwave stick, re-included, re-scanned for new devices in OH, device found (new nodeID), still unknown with no channels.

Can you provide the device ID numbers? Something like 0086: 0002:0009?



If that’s not what you are looking for, please let me know where I can find this ID in the UI.

That’s not it. Look on the thing ui page under properties manufacturer ID and Ref. Also should be in the node 15 xml file in the userdata/zwave folder.

I expect that you need to wake up the device so that it can be discovered as from the properties it seems this has not happened yet.

1 Like

Good catch ! I have 2 DSB09’s (not sure if same as OP) but have both powered, so forgot there was a battery option. Should have been more observant.


1 Like

This is all I see.

@chris The device shows ONLINE in OH and I’ve already excluded then re-included the device. Surely that action “woke it up”? If I remove the device in OH, then re-scan, it will appear and when I add it to OH, I get this same page.

@chris I pushed the only button on the device. The light blinked a few times then went solid, which according to the manual means the device is part of a zwave network.

I don’t know, but it’s certainly not guaranteed. If the device is sleeping, then it will need to be woken for the binding to communicate with it. Given that the manufacturer information is not presented here, that is my initial thought that the device needs waking up, but maybe there’s other explanations.

Normally, if a device is sleeping (as this device appears to be given it’s “not listening” - ie sleeping) there will be a specific way to wake it up so the binding can communicate with it.

Have you already checked the debug logs to see what is happening? With that you will have a lot more information than me - I’m just trying to help based on the limited info and again the main thing that pops up here is that there is no manufacturer information being presented, which normally means the device hasn’t initialised.

Can you suggest which logs/patterns to set to DEBUG? I can see activity when my door sensors open/close, but didn’t see anything when I clicked the button on this energy monitor.

Please take a look at the binding docs - it’s described there :slight_smile:

Yep, found that shortly after I posted. Not seeing anything from ‘node15’ which is this device. How can there be no log activity but OH reports ‘Online’? I even powered off / on the device and nothing showed in the logs.

I’m not really sure and can’t comment on your logs without seeing the logs. I don’t know what you’ve recorded - if it is from the binding startup or some time later for example so it’s difficult to draw any conclusions and I could really only speculate?

Again though, if there is no communication, then this is why the device is unrecognised. I’m not familiar with the device, but the controller says it doesn’t listen, so the binding will not try and send anything to it unless the device sends first. This is why I talk about waking up the device - normally there’s a specific button press to do this - eg pressing a button 3 times, or holding it down for 5 seconds, or something like that. Normally this is in the manual, but not always.

That’s probably not surprising - it would depend on what the device does under such circumstances - certainly the binding wouldn’t do anything in this event.

Maybe the device is not properly included into the network - you could try to exclude it an reinclude it. Then provide the logs for this.

There also could be communication issues. How close is the device to the controller? If this is the same device I have it is 300 series zwave, so is not Zwave plus, so network wide inclusion is not available. Lastly on the communication idea, have you tried fresh batteries? Again if it is the same device just one push of the dark button below the batteries should either include, exclude or wake the device.

Also what are you running on? There were issues with the aeotec Gen5 controller on Rpi4. Are you on the same HW as when it was working and just updated OH?

Lastly there were improvements in zwave battery inclusion in OH3.3. I’m not sure that will help since there has to be communication, but is something to consider.