Unsupported language error

I get the following error:

Error during trainer initialization: Unsupported language: nl

Where does Habot read the language preference? Changing the language in the paper UI doesn’t seem to affect anything.

It would be great if a fallback language would also be supported.

Have you tried setting this setting explicitely to “English”? if you simply leave it blank I reckon it’ll use the language of the OS.


I get the same error, Tried setting language to English in paper ui, but still same error. Even after reboot.

That’s unfortunate - did you click Save (below the map) after setting it to English? Normally it should work :man_shrugging:

Unfortunatly i did. But i can wait. Happy holydays :wink:

Hello, I found this on the forum: Cant change language. Do you think this could be the problem? Im not shure what to put in the file for english. I gues replace “duser” with “english”, “nl” with “en” and “NL” with “US”? I will give it a try as soon as i can get to my server. I will keep you posted. Greets

I don’t think it matters. And I really don’t know what else to suggest, except try the next snapshot version, because I just merged https://github.com/openhab/org.openhab.ui.habot/pull/32 which adds Dutch support to HABot!