Update 2.5.1 to 2.5.2: edited sitemaps do not necessarily refresh?

  • Platform information:
    • Hardware: Intel Core i3-2310M
    • OS: Windows 10 Home 10.0.186363
    • Java Runtime Environment: Zulu 8
    • openHAB version: 2.5.2 stable
  • Issue of the topic: please be detailed explaining your issue
  • Please post configurations (if applicable):
    sitemap: Image url=“” refresh=1000
  • If logs were generated please post these here using code fences:
    I found no error message in logs

I have an ESP32 camera board that streams to the IP address
It displays fine in a browser tab opened to that IP
In previous openHAB 2.5.x versions, it displayed fine on basicui via sitemap entry:
Image url=“” refresh=1000

However, with openHAB 2.5.2 this only results in a broken image link on the UI & I am seeing no error message in the logs.

Have you tried stopping OH, cleaning the cache, and rebooting? Has the IP address changed?

Yes, I’ve stopped OH, clean cache, & rebooted more than once. Yes, IP address changed, but I changed that sitemap entry to match the new IP.

It worked before OH 2.5.2 & I installed 2.5.2 by using the backup (from OH 2.5.1) & restore scripts

Downgrade to 2.5.1 and see if it still works, as that will confirm it’s an issue with 2.5.2

If it does work then open an issue on github to have it fixed.

Yes, H102, thanks for responding. Per the recommended approach, I’m checking first with OH community & what you suggest was my next plans. I just ran OH 2.5.1 & the Image url=“http…” works fine. I had upgraded from 2.5.1 because its MQTT broker seemed to go offline a bit too easy. I’ll wait a bit for OH community responses & than open an issue on github.

That is not the default URL for snapshot or mjpeg stream from esp32.

See the ipcamera binding readme as it has the URLs in there and how to set it up. If you want to use the stream on multiple apps and tablets at the same time you will need the binding to make that possible.

1 Like

Thanks for responding & suggesting, matt1. I looked some at your ipcamera binding readme, but then experimented more with Image url=“” refresh=1000

Image url… eventually worked, especially when I created a new sitemap file that included it. The hangup seems to be with another issue or “feature” of OH 2.5.2. Once OH 2.5.2 loads a sitemap, OH2.5.2’s storage of the sitemap seems to resist changing, even when one stops OH, clears the cache & restarts OH. One can edit a sitemap & save it, but then the log does not necessarily show “refreshing model ‘xxx.sitemap’” & likewise does not necessarily show a change on the UI.

PS I edit OH config files with Notepad++ on a Windows 10 computer

Does anyone else notice this behavior of OH 2.5.2?