Update seemed to break zwave controller

I’m running Raspbian (might have renamed now) and last night I did an update and rebooted and it seems it can no longer initialize the zwave controller.

There are the commands I ran (from my bash history):

sudo apt update
sudo apt upgrade
  • Platform information:
    • Hardware: Raspberry Pi 3B
    • Java Runtime Environment: openjdk version “1.8.0_265”
    • openHAB version: 2.5.7

I don’t remember what version I had before but it wasn’t too old, I’m sure it was a 2.5.x version. At startup, I started seeing a lot of errors, I restarted it a few times and it was the same, I’ve removed all my rules for now to reduce errors and it seems all the issues are from a non-working z-wave controller. The mqtt items and stuff all seem to work as well as they did before. The logs show this:

2020-08-19 08:28:04.689 [ERROR] [st.core.internal.thing.ThingResource] - Exception during HTTP PUT request for update config at 'things/zwave:serial_zstick:831e87fd/config'
java.lang.IllegalStateException: Thing with UID zwave:serial_zstick:831e87fd has no handler attached.
        at org.eclipse.smarthome.core.thing.internal.ThingRegistryImpl.updateConfiguration(ThingRegistryImpl.java:95) ~[?:?]
        at org.eclipse.smarthome.io.rest.core.internal.thing.ThingResource.updateConfiguration(ThingResource.java:438) [bundleFile:?]
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_265]
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_265]

I also see a lot of errors of the type:

Caused by: java.io.IOException: Broken pipe
Caused by: java.io.IOException: Connection reset by peer
Caused by: org.eclipse.jetty.io.EofException

I was able to track down my latest updates the broke my system in case it makes a difference, I had last updated openhab with the following:

/var/log/dpkg.log.1:2020-07-04 07:57:59 status installed openhab2:all 2.5.6-2
/var/log/dpkg.log.1:2020-07-04 07:57:59 status installed openhab2-addons:all 2.5.6-2

and updated last night to:

/var/log/dpkg.log:2020-08-18 22:22:56 status installed openhab2:all 2.5.7-1
/var/log/dpkg.log:2020-08-18 22:22:56 status installed openhab2-addons:all 2.5.7-1

the set of updates that also happened alongside the openhab update were:

2020-08-18 22:20:42 status installed base-files:armhf 9.9+rpi1+deb9u13
2020-08-18 22:20:43 status installed e2fslibs:armhf 1.43.4-2+deb9u2
2020-08-18 22:20:44 status installed e2fsprogs:armhf 1.43.4-2+deb9u2
2020-08-18 22:20:50 status installed perl-base:armhf 5.24.1-3+deb9u7
2020-08-18 22:21:01 status installed libcomerr2:armhf 1.43.4-2+deb9u2
2020-08-18 22:21:01 status installed libss2:armhf 1.43.4-2+deb9u2
2020-08-18 22:22:43 status installed perl-modules-5.24:all 5.24.1-3+deb9u7
2020-08-18 22:22:43 status installed libperl5.24:armhf 5.24.1-3+deb9u7
2020-08-18 22:22:43 status installed glib-networking-common:all 2.50.0-1+deb9u1
2020-08-18 22:22:43 status installed libjpeg62-turbo:armhf 1:1.5.1-2+deb9u1
2020-08-18 22:22:43 status installed librsvg2-2:armhf 2.40.21-0+deb9u1
2020-08-18 22:22:43 status installed libluajit-5.1-common:all 2.0.4+dfsg-1+deb9u1
2020-08-18 22:22:43 status installed mime-support:all 3.60
2020-08-18 22:22:43 status installed libcurl3:armhf 7.52.1-5+deb9u11
2020-08-18 22:22:44 status installed install-info:armhf 6.3.0.dfsg.1-1+b1
2020-08-18 22:22:46 status installed tzdata:all 2020a-0+deb9u1
2020-08-18 22:22:53 status installed nfs-common:armhf 1:1.3.4-2.1+deb9u1
2020-08-18 22:22:53 status installed libglib2.0-0:armhf 2.50.3-2+deb9u2
2020-08-18 22:22:53 status installed libgnutls30:armhf 3.5.8-5+deb9u5
2020-08-18 22:22:53 status installed glib-networking-services:armhf 2.50.0-1+deb9u1
2020-08-18 22:22:54 status installed initramfs-tools:all 0.130
2020-08-18 22:22:54 status installed perl:armhf 5.24.1-3+deb9u7
2020-08-18 22:22:54 status installed libx11-xcb1:armhf 2:1.6.4-3+deb9u2
2020-08-18 22:22:54 status installed libc-bin:armhf 2.24-11+deb9u4
2020-08-18 22:22:54 status installed luajit:armhf 2.0.4+dfsg-1+deb9u1
2020-08-18 22:22:56 status installed openhab2:all 2.5.7-1
2020-08-18 22:22:56 status installed glib-networking:armhf 2.50.0-1+deb9u1
2020-08-18 22:22:56 status installed openhab2-addons:all 2.5.7-1
2020-08-18 22:22:56 status installed systemd:armhf 232-25+deb9u12
2020-08-18 22:22:56 status installed libx11-doc:all 2:1.6.4-3+deb9u2
2020-08-18 22:23:14 status installed man-db:armhf
2020-08-18 22:23:14 status installed hicolor-icon-theme:all 0.15-1
2020-08-18 22:23:14 status installed libx11-data:all 2:1.6.4-3+deb9u2
2020-08-18 22:23:14 status installed libdbus-1-3:armhf 1.10.32-0+deb9u1
2020-08-18 22:23:14 status installed libpython3.5-minimal:armhf 3.5.3-1+deb9u2
2020-08-18 22:23:14 status installed libcups2:armhf 2.2.1-8+deb9u6
2020-08-18 22:23:14 status installed curl:armhf 7.52.1-5+deb9u11
2020-08-18 22:23:14 status installed libcurl3-gnutls:armhf 7.52.1-5+deb9u11
2020-08-18 22:23:14 status installed libpython3.5-stdlib:armhf 3.5.3-1+deb9u2
2020-08-18 22:23:15 status installed libx11-6:armhf 2:1.6.4-3+deb9u2
2020-08-18 22:23:20 status installed python3.5-minimal:armhf 3.5.3-1+deb9u2
2020-08-18 22:23:20 status installed libx11-dev:armhf 2:1.6.4-3+deb9u2
2020-08-18 22:23:22 status installed dbus:armhf 1.10.32-0+deb9u1
2020-08-18 22:23:23 status installed openjdk-8-jre-headless:armhf 8u265-b01-0+deb9u1
2020-08-18 22:23:34 status installed python3.5:armhf 3.5.3-1+deb9u2
2020-08-18 22:23:35 status installed openjdk-8-jdk-headless:armhf 8u265-b01-0+deb9u1
2020-08-18 22:23:35 status installed libpython3.5:armhf 3.5.3-1+deb9u2
2020-08-18 22:23:35 status installed librsvg2-common:armhf 2.40.21-0+deb9u1
2020-08-18 22:23:36 status installed libgdk-pixbuf2.0-0:armhf 2.36.5-2+deb9u2
2020-08-18 22:23:36 status installed openjdk-8-jre:armhf 8u265-b01-0+deb9u1
2020-08-18 22:23:36 status installed openjdk-8-jdk:armhf 8u265-b01-0+deb9u1
2020-08-18 22:23:36 status installed libc-bin:armhf 2.24-11+deb9u4

Have you tried restarting OpenHAB? Most people find it needs at least one restart after upgrading. Some people have needed three.

yeah i restarted a few times. i rolled back and it worked… well sorta. i had to unplug the usb device in the end and it finally worked. i had rebooted and tried that “soft reset” option that claims to simulate unplugging. i’m pretty sure i unplugged the usb device before downgrading too. i’ll try upgrading again later this week when the heat wave passes. (our a/c is controlled via zwave and we got used to not walking up to the thermostat to control it)

A new release is expected this weekend, I believe.

I recently had an rasbian update that removed all my users from the tty group. This broke my zwave hat. I added the openhab user back to the tty group. Fixed it. Dunno what package or update made the change. I didn’t bother digging that deep.

1 Like