Update to openhab 2.3 kinda broke everything

It would be quite a coincidence if it was an SD card problem that immediately popped up after an update. Also, some 3 weeks ago, I experienced some trouble with rules with crontabs. Advice ‘new SD card’.
Did that, top brand new SD card… still the same rule problem.
If now again it is a corrupted SD card, then I might as well stop.

I have 3 item files… They all experience trouble, so how to find ot what kind of problem they have. They were all recently syntax checked in eclipse smart designer and they all were fine.

Also… I checked some other sitemao files that use completely unrelated items files, same problem.
Only my Airquality sitemap seems to correctly load the Airquality items file

I didn’t see any major breaking change on OH 2.3 with regards to items that would cause the issues that you are experiencing.

Other users are also not complaining about Cannot retrieve item errors… (which are usually related to problematic/erroneous items files)

I would try to copy the files and rename them to see if they load up correctly.

Do you see any items being listed in the console with the command items list ?

I will try that.
What console are you referring to?


ah yes that one.
yes see many many items pass by

give this a try: Clear the Cache

(just to check)

and then monitor the logs again

did that, same result.
yes got some errors like

018-05-28 16:44:42.026 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-gpio, openhab-transformation-RegEx, openhab-transformation-XSLT': Error restarting bundles:
	Unable to acquire the state change lock for the module: osgi.identity; type="osgi.bundle"; version:Version="0.10.0.oh230"; osgi.identity="org.eclipse.smarthome.model.script.runtime"; singleton:="true" [id=139] STARTED [STARTED]
	2018-05-28 16:44:49.664 [ERROR] [org.openhab.binding.gpio            ] - FrameworkEvent ERROR - org.openhab.binding.gpio

But they may be the result of what I added to the addons.cfg.
Furthermore ofcourse the massive errors about not being able to find items and groups.
well, yes the problem is persisting.Dont seemuch use in reopening it in new thread.
Anyway, I sincerely appreciate your help, but I think I just go back to 2.2 and maybe, if I feel like it in future, will do a clean install of 2.3 and just copy my sitemap and itemfiles, see how that goes.

Just a small addition… you might be on to something with errors in my itemsfile. Eventhough I rechecked with eclipse smartdesigner and saw no errors and eventhough they never gave me problems in 2.2… I recreated a small itemsfile containing some of the missing groups and items…and those started to pop up. So lets see what I can do with copying parts of the one file to another and see where it goes bust.
Anyay, again thanks for yr help

1 Like

btw: this tool is a bit outdated… I would try to switch to VSCode which is much better

1 Like

yes so I heard. I may do that.If that immediately spots an error in my itemsfile it might be worth it.

Anyway, might be a good moment to restructure my itemsfile in much smaller sections.
So, I may hold on to 2.3 a bit longer and see what I can ’ fix’
Did I understand correctly that I can remove the bindings I added from the addons.cfg again?

1 Like

yes, you can remove that line (comment it out)
it should work fine

1 Like


ESHD is pretty much dead. It hasn’t been updated since OH 2.0 and even that version was incomplete. I highly recommend VSCode with the openHAB extension which actually passes the code to your running OH to parse it meaning it’s always up to date with the syntax.

Thanks Rich, I will do that.
Am going through my test itemsfile and already came across some items that would not load eventhough for the life of me I cant see a problem.
Will try some more… with VS

I went through the same martyrdom you did when upgrading from 2.3 snapshot to 2.4 snapshot.
I finally did it the way you proposed, clean install and copying the config back: worked right out of the box.

Maybe I will do that then. might be faster. tnx

1 Like

Slight update:
I copied my entire unaltered backup Itemsfile into a new itemsfile… and suddenly things come to life, eventhough I still miss some stuff that I can see is present in the file (Like an entire room), but wont show up anyway, there is progress.
I just hope that this doesn’t suggest my new 3 weeks old SD card is corrupted
Will post updates

So there are two ways an SD card can become corrupted:

  1. Power failure during a write
  2. SD care wears out

The solution to both is the same, rebuild the system. However, with 2 you need to rebuild on a new card. Because the solution to both is the same, and I tend to value people’s time or highly, with a lack of information to tell me otherwise, I always have people rebuild on a new SD card.

In your case, 2 is highly unlikely but 1 could have happened. Did you yank the plug on the Pi or otherwise lose power recently?

Thanks Rich. I am always very careful with shutting down the raspberry, always issue a shutdown now command and wait a while before I remove power

@Dim @sihui @rlkoshak
And suddenly, after messing a bit more with my main items file, it all started working again, even some sitemap/item combo’ s that were completely separate.

nevertheless… I still may do a fresh install on a new SD card, just to be sure.
All thank you for your help


This morning not a single error message left. Albeit there were 3 items somewhere in a completely unrelated file that still woudnt load. Redid that file and its OK now

Noticed that some of my Transformation services had not survived the transfer, so needed a re-install of those services in paper UI. Not a biggie.

on the plus side after all (your and) my troubles: the AirQuality binding that had given me lots of trouble before seems to work flawlessly now. :slight_smile:
I’ d say that’s a plus and I am again a happy camper

1 Like