Update to OpenHAB 3

Hello

Looking for some guidance, I have been using OpenHAB for a few years and love it but I really struggle with the coding I know most of you will say I shouldn’t be using it then but am trying to learn

I have tried to update me system from 2.5 to 3 and have now made a major mistake I should have left it how it was as not understanding the process i have messed up. I have tired to follow the guidelines.

I seem to have successfully installed OpenHAB 3 however I can’t access the UI or access anything on the app?? My items and sitemap seem to be in the new location but I can’t work out why I can’t access anything or get it to work

Without guidance am going to try a fresh install and try to copy my old settings but If anyone could help it would be amazing

Am so sorry am not to your standards in code and feel bad as having to ask for your help

I don’t think you’ll find too many on this forum that will tell you that. If you want to learn to do this then you should be using it and you are welcome to keep coming to these forums to keep learning. From what I’ve seen over the years, the only time users are advised to step away from OH is when they don’t want to learn and simply expect the helpers on the forum to do all the work for them.

Now to your problem:

There are several different ways to upgrade from 2.5 to 3 depending on how your system was originally set up, and not only will what the answer is change depending on those details, who is best positioned to actually get you to that answer could be different. So you’re going to have to provide more details before we can narrow down the issue for you. Try to answer as many of these kinds of questions as you can think of:

  1. What hardware is your OH installed on?
  2. What method did you use the first time to install OH 2?
  3. Can you verify that OH is even starting up or running?
  4. How are you trying to access the OH3 UI?
  5. When you try to access the OH3 UI does your browser report any errors? If not what do you see, just a blank screen or something else?
  6. Can you access the log files? Are there errors in the log files? If so show us those errors.
  7. Have you searched the forum for other posts that describe similar problems to what you’re experiencing? Did the solutions in those posts help even a little or seem to makes things worse?

The more details you can provide about your specific situation the more easily some one here can identify your issue and get you back on the right path.

3 Likes

Hello

Thanks for your understanding and reply

I have OpenHAB running on a raspberry pi and can’t remember how the install happened but I would have most likely been a installed from a download on the website

I can SSH in to the system and it is showing that OpenHAB is running? And is showing the version as 3 when it was 2.5. I have tried the use the UI and it asks to log in when I do it doesn’t show anything?

My normal way of accessing OpenHAB is by the app or UI on a PC (up address:8080) and it now just shows a blank screen it use to show a number of different options

I am not sure about log files am sorry. Am happy to try and learn

I have searched the forum one suggestion was to stop OpenHAB running and clear the catch and restart but that hasn’t worked for me. I haven’t found any else

Any support would be helpful. I spent a lot of time building the items and sitemaps understand for most that would be easy but I read loads of forums to get things working

So when you try to access the UI from your browser you do see this page (with your ip and port number of course):
image
But when you sign in using this page you get only a blank screen. Is that correct?

Also can you confirm the full version of OH that you have installed. Are you working with the 3.0 stable release or some more recent version (a milestone or snapshot?)?

So loging in to your Pi and running the command
sudo systemctl status openhab
what is the output ?
What is the java version that is running
java -version

Sorry for the late reply openhab has been down all day

yes when i access the UI from my browser i see that page and when i login i just get a blank screen

when i SSH it shows 3.0.1 - Release Build i think this is the 3.0 stable?

sudo systemctl status openhab

● openhab.service - openHAB instance, reachable at http://openHABianPi:8080
   Loaded: loaded (/usr/lib/systemd/system/openhab.service; enabled; vendor preset: enabled)
  Drop-In: /etc/systemd/system/openhab.service.d
           └─override.conf
   Active: active (running) since Fri 2021-03-12 09:23:44 GMT; 6h ago
     Docs: https://www.openhab.org/docs/
           https://community.openhab.org
 Main PID: 507 (java)
    Tasks: 178 (limit: 4915)
   CGroup: /system.slice/openhab.service
           └─507 /usr/bin/java -XX:-UsePerfData -Dopenhab.home=/usr/share/openhab -Dopenhab.conf=/etc/openhab -Dopenhab.runtime=/usr/share/openhab/runtime -Dopenhab.userdata=/var/lib/openhab -Dopenhab.logdir=/var/log/openhab -Dfelix.cm.d

Mar 12 09:23:44 openHABianPi systemd[1]: Started openHAB instance, reachable at http://openHABianPi:8080.
Warning: openhab.service changed on disk. Run 'systemctl daemon-reload' to reload units.
lines 1-14/14 (END)

java -version

openjdk version "11.0.10" 2021-01-19 LTS
OpenJDK Runtime Environment Zulu11.45+27-CA (build 11.0.10+9-LTS)
OpenJDK Client VM Zulu11.45+27-CA (build 11.0.10+9-LTS, mixed mode)

I have used a copy of my backup to try the install again

This time am struggling with updating the Java to 11 can’t work out how I did it the first time

I have tried everything I did the first time but still won’t update

I have both the first and second attempt so any help on either would be helpful