Upgrade 3.2 -> 3.3 addons.cfg is ignored features not installed

Hi everyone,

Iam running OH as docker container and just updated from 3.2 stable to 3.3 stable.
The RFLink binding Iam using to control my rollershutter relies on the OH serial transport feature (org.openhab.core.io.transport.serial).

I added in my “/services/addons.cfg” the following line: “transport = serial” to get the serial transport feature installed automatically after the container changed. This worked without any problem until now. After the upgrade 3.2 → 3.3 the transport feature did not get installed.

Manually installing the feature with “feature:install openhab-transport-serial” through Karaf-Console however worked without any issue.

Is this a known issue ?

Thx for any help.

If that worked in the past then you were lucky. The transport bundles are not considered as add-ons. It could be that fixes/changes to the FeatureInstaller as a result of the addition of the community marketplace and the 3rd party add-on service lead to this behavior.

The transport features should be automatically installed if an add-on that needs them is installed. If that is not the case, then the feature-definition of the add-on is wrong. Which add-on needs the serial feature and does not automatically install it?

Thanks for the fast feedback.
The addon Iam using for 5 years to control my Somfy rollershutter is RFLink. Since I use it it never installed its dependency and therefore I used addons.cfg to automate that issue at least.

Ok, that’s not an official add-on and you probably use a .jar in your add-ons folder, correct? If you drop a .jar in the addons-folder, you need to take care of your dependencies manually. Maybe the author can create a .kar instead of a .jar or bring it to the official distribution.

In fact I always was wondering why the addon never made it to the official distribution. I guess the author does not want to get too deep involved with maintaining it. I always was happy that the addon somehow moved on as it is essential for me and for others I guess. At least I do not know an official addon which supports Somfy rollershutter using rfxcom transmitter.

To move forward from here: Is there any chance it will be possible to install the serial transport via addons.cfg in the future again ? If not (quick and dirty) is there another official addon which will install serial transport as dependency to solve me issue ?

I don’t think that’ll work again. The serial binding should install it.

Alright. I will give that I try.

Thank you again very much for your fast and useful support!