Upgrade from 2.4 stable to 2.5 not working


I just performed an update from OH2.4 to 2.5 using the openhabian-config tool.
After reboot of the Raspberry Pi OH2.5 doesn’t start up.
I don’t seeany messages in /var/log/openhab/openhab.log.
I see a lot of Openhab Java proccesses running, but nothing starts up correctly.

I even can’t connect to Client:
$OPENHAB_RUNTIME/bin/client -p habopen
Logging in as openhab
Failed to get the session.

Has anyone an idea, what I could try?
Thanks a lot


  • Platform information: Openhabian on Pi 3B+
    • Hardware: CPUArchitecture/RAM/storage
    • OS: what OS is used and which version
    • Java Runtime Environment: which java platform is used and what version
    • openHAB version:
  • Issue of the topic: please be detailed explaining your issue
  • Please post configurations (if applicable):
    • Items configuration related to the issue
    • Sitemap configuration related to the issue
    • Rules code related to the issue
    • Services configuration related to the issue
  • If logs where generated please post these here using code fences:

Do you installed openHABian as a independent operating system?

I’m running on Openhabian.
I tried updating again, it worked.
Now my serial Z-Wave Controller goes down every 30 seconds…

1 Like

That sounds like the same Effekt I have updating from stable 2.4 to 2.5 milestone 4 or 5.

How did you fixed it?

Those that had this issue found invalid addons listed in addons.cfg or addons.config. The loader tries to reload them and restarts all addons.


I did not find a fix. Luckily it was a test system.

So I installed a clean 2.4 with no bindings. After that update to 2.5 m5, and then install zwave binding.

That works for me…

No idea actually what I have to do on my live system.

Best regards


corrected addons.config fixed the isue