Upgrade from OH4.1.1. to 4.1.2

I wanted to upgrade to OH4.1.2 under ubuntu with my initial modified yml file see below

services:
  openhab:
    image: "openhab/openhab:4.1.2"
    restart: always
    network_mode: host
    volumes:
      - "/etc/localtime:/etc/localtime:ro"
      - "/etc/timezone:/etc/timezone:ro"
      - "/home/mynuc/docker/openhab4.1.2/addons:/openhab/addons"
      - "/home/mynuc/docker/openhab4.1.2/conf:/openhab/conf"
      - "/home/mynuc/docker/openhab4.1.2/userdata:/openhab/userdata"
    environment:
      CRYPTO_POLICY: "unlimited"
      EXTRA_JAVA_OPTS: "-Duser.timezone=Europe/Amsterdam"
      OPENHAB_HTTP_PORT: "8080"
      OPENHAB_HTTPS_PORT: "8443"

the command run docker compose up -d failed and I checked with suggestion snap info openhab and got the feedback shown below.

snap info openhab
name:      openhab
summary:   openHAB smart home server
publisher: openHAB Foundation e.V. (openhab)
store-url: https://snapcraft.io/openhab
contact:   https://github.com/openhab/openhab-snap
license:   EPL-1.0
description: |
  openHAB - a vendor and technology agnostic open source automation software for your home.
  An image of Ubuntu Core with some USB items added to the gadget snap is available at
  http://people.canonical.com/~okubik/openhab/
  If you would like to add a USB controller or other device, please raise an issue at git
  https://github.com/openhab/openhab-snap/
  webgui is available at user defined port(default is 8080 for http and 8443 for https)
  http://<snap device address>:{specified http port}
  https:///<snap device address>:{specified https port}
  Port settings can be altered by user, refer to:
  $ openhab.help
snap-id: WpdPxW72JupkC8XTgaJsig3LEHdrR56x
channels:
  latest/stable:    4.1.1                 2024-03-28 (2629) 184MB -
  latest/candidate: 4.2.0.M2              2024-04-11 (2647) 184MB -
  latest/beta:      4.1.1                 2024-03-28 (2629) 184MB -
  latest/edge:      4.2.0-SNAPSHOT-bn4077 2024-05-12 (2695) 184MB -

Why is docker 4.1.2 not in the list?

Because you didn’t install docker as a snap? :man_shrugging:

We have no idea how you installed Docker so we’re not in a good position to help. We are not a Docker support forum so again, we are not in a good position to help.

Keep in mind that openHAB can be installed through snap, but that’s going to be completely independent and unrelated to running openHAB in Docker.

Thanks I found the issue. Version 4.1.2 is running fine (PC and Android access) however VSC is complaining with

Usage of deprecated config => openhab.host <= detected.
openHAB vscode extension has been activated
[Error - 2:13:18 PM] Connection to server is erroring. Shutting down server.
[Error - 2:13:18 PM] Connection to server is erroring. Shutting down server.

It seems related to settings.json but don’t know what can be wrong. This is my file

{
    "openhab.connection.basicAuth.password": "habopen",
    "openhab.connection.basicAuth.username": "admin",
    "oh-alignment-tool.enableBetaFeatures": true,
    "openhab.languageserver.remotePort": 5007,
    "editor.foldingMaximumRegions": 10000,
    "workbench.startupEditor": "none",
    "editor.autoIndent": "brackets",
    "openhab.useRestApi": false,
    "openhab.connection.port": 8080,
    "openhab.itemCasing": "camel",
    "openhab.languageserver.remoteEnabled": true,
    "editor.codeActionsOnSave": {},
    "git.autofetch": true,
    "explorer.confirmDelete": false,
    "workbench.colorTheme": "Atom One Dark",
    "workbench.iconTheme": "vscode-icons",
    "editor.indentSize": "tabSize",
    "editor.tabSize": 2,
    "oh-alignment-tool.minimumIndentAmount": 2,
    "security.allowedUNCHosts": [
        "192.168.100.50",
        "MYNUC-DESKTOP"
    ],
    "php.validate.executablePath": "",
    "[typescript]": {
        "editor.defaultFormatter": "vscode.typescript-language-features"
    },
    "liveServer.settings.donotShowInfoMsg": true,
    "editor.stickyScroll.enabled": false,
    "openhab.connection.authToken": "oh.openhab.PU86SSjU0dUGHDRkZNlv7Sele5R1Z7IvnAknlrQZCpXyVWonQhWbfLa81ctjvHiVHFWr3Yje5g1JeeLZ9NQ"
}

This is a picture what I get in the GUI. I never saw this before

It’s been years since I’ve used the VSCode openHAB extension but the warnings and errors are fairly straight forward.

The first is complaining that you have an openhab.host property set somewhere and that field is deprecated. I don’t actually see the property here in your settings.json but I also don’t see any property telling VSCode the IP address or domain name of the openHAB host machine. This probably leads to the second error…

The second error is that the VSCode extension cannot connect to the LSP port (5007) on the running openHAB. Since there is no property telling it where OH is running it’s probably trying to connect to localhost.