Upgrade to 2.5 - not starting properly

  • Platform information:
    • Hardware: Raspberry Pi
    • OS: openhabian
    • Java Runtime Environment: OpenJDK Runtime Environment (Zulu Embedded (build 1.8.0_152-b76)

I was running on openHAB 2.5.0~S1756-1 (Build #1756) without issue
upgraded via apt today and now unable to get openhab to start
one error repeating in the log

11:45:04.400 [ERROR] [.core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-http1, openhab-persistence-mapdb, openhab-voice-marytts, openhab-binding-insteonplm1, openhab-binding-nest, openhab-misc-openhabcloud, openhab-binding-network, openhab-binding-amazonechocontrol, openhab-binding-sonos, openhab-misc-ruleengine, openhab-ui-habpanel, openhab-action-pushover, openhab-binding-zwave, openhab-ui-restdocs, openhab-misc-homekit-test, openhab-binding-mqtt, openhab-transformation-map, openhab-ui-basic, openhab-binding-ntp, openhab-binding-astro, openhab-ui-habmin, openhab-ui-paper': Error:
	Error downloading mvn:io.netty/netty-all/4.0.32.Final
	Error downloading mvn:io.netty/netty-all/4.0.32.Final
	Error downloading mvn:org.zeromq/curve25519-java/0.1.0
	Error downloading mvn:org.zeromq/curve25519-java/0.1.0
	Error downloading mvn:org.bouncycastle/bcprov-jdk15on/1.51
	Error downloading mvn:com.nimbusds/srp6a/1.5.2
	Error downloading mvn:com.nimbusds/srp6a/1.5.2

My addons.config


Appreciate any thoughts on how to resolve - right now I’m stuck.
Thank you

homekit-test looks suspicious. Try removing that entry.

Stop OH, clean the cache and reboot.

sudo systemctl stop openhab2

sudo openhab-cli clean-cache

sudo reboot

After OH has restarted and everything has fully loaded and the issue remains then stop OH again and reboot again.

Thanks @Bruce_Osborne - removing that entry seems to have fixed the error in the log, however after restarting I’m still unable to get into the UI, though there is nothing in the log at all in terms of errors.

After visiting http://openhab:8080, it redirects to http://openhab:8080/start/index
and I get the following

Problem accessing /start/index. Reason:

Not Found

Wait a bit. It could be still downloading bindings.

@H102 I’ve tried these steps. No Log errors, and the UI is started, however I get the following.

Welcome to openHAB 2
No user interfaces installed.

Try commenting out package=“standard” in addons.cfg then clean cache and restart.

Looks like somehow my addons.config got reset during this process. I replaced it with my content above (minus homekit-test) and all seems to be working after an update.

Thanks @Bruce_Osborne & @H102

addons.cfg or addons.config?

This should not have been reset during the upgrade.:thinking:

It didn’t happen during the upgrade - my original addons.config was still there.
I’m pretty sure I didn’t adjust it/delete it/etc, but after the stop/cache clear/reboot - the addons.config was changed and didn’t have all the content that my setup needs.

That’s good.

This not so good as /var/lib/openhab2/config/org/openhab/addons.config contains the parameters that we set in /etc/openhab2/services/addons.cfg (this file is parsed, and entered in ConfigAdmin with config pid: org.openhab.addons ). Cleaning the cache should have no negitive effect of this file. BTW NEVER make a change to addons.config with OH running.

Best part is you have it working.:+1:

Perhaps a new Karaf issue? I tend to use the nuclear approach.
shut down OH
delete contents of cache & tmp folders in userdata
restart OH

So my /etc/openhab2/services/addons.cfg file looks stock, everything commented, no packages mentioned in there at all.

So that probably explains what happened, since Cache was cleared, it was like a “first time start” of OH, and so copied the empty .cfg file over to /var/lib/openhab2/config/org/openhab/addons.config.

I’m not sure about that, as I have never had an issue similar to this after clearing the cache and I use PaperUI for addons with addons.cfg as you describe above, all commented out.:thinking:

As mentioned above, glad the problem is solved.:+1: Please click the post with the solution. Thanks

1 Like