Upgrade zwave binding from 1.x to 2.x

Hi, I followed this clean guide and I successfully updated my OH 1.X to OH 2 beta4.
Everything works as expected and now, after a couple of weeks that the system was up and running I want upgrade my zwave binding to 2.X but I cannot uninstall previous binding.
From karaf console if I run " feature:uninstall openhab-binding-zwave1" all I get is this error:

2016-11-13 15:21:58.981 [ERROR] [st.core.extensions.ExtensionResource] - Exception while uninstalling extension: org.osgi.service.resolver.ResolutionException: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=openhab-ui-habpanel; type=karaf.feature; version="[2.0.0.SNAPSHOT,2.0.0.SNAPSHOT]"; filter:="(&(osgi.identity=openhab-ui-habpanel)(type=karaf.feature)(version>=2.0.0.SNAPSHOT)(version<=2.0.0.SNAPSHOT))"

The same error is presents on the openhab log file if I try to uninstall zwave1 binding from paperUI.
Any suggestion ?

Other people are experiencing similar issues…

Try upgrading OH2 to the latest snapshot… this should fix it

Alternatively, try to uninstall HABPanel first and then uninstall the binding (backup your HABPanel configs)

See here:

I have installed beta 4 by using the apt repository.Is it possible upgrade to latest snapshot by changing the apt repo ?

I am not sure… (never tried going from OH2 Beta 4 to Snapshot). I only use snapshot and I upgrade it with apt-get.

You could keep a backup of your configs, remove the Beta and then install clean the Snapshot to be covered :wink:

Ok I will try and report back here the results.

Thank you!

Ok I’ve updated my openhab 2 beta4 installation to the latest shapshot by using the apt repositories.
There is no a direct update path, and I’ve done the following steps:

  • First I deleted previous openhab2 beta apt source file:
sudo rm /etc/apt/sources.list.d/openhab2.list
  • Then I added snapshots source file and key:
echo 'deb https://openhab.ci.cloudbees.com/job/openHAB-Distribution/ws/distributions/openhab-offline/target/apt-repo/ /' | sudo tee /etc/apt/sources.list.d/openhab2.list
echo 'deb https://openhab.ci.cloudbees.com/job/openHAB-Distribution/ws/distributions/openhab-online/target/apt-repo/ /' | sudo tee --append /etc/apt/
wget -qO - 'http://www.openhab.org/keys/public-key-snapshots.asc' | sudo apt-key add -
  • Then I updated the apt repos:
sudo apt-get update
  • Then I deleted beta4 version and installed the shapshot version (I choosed “Y” to replace all pre-existing files)
sudo apt-get remove openhab2-offline
sudo apt-get install openhab2-offline

Configuration files from beta4 was mantained but you need to re-install and configure all bindings