Upgraded to 2.5m2 by mistake

While looking for a different option, I accidentally clicked on the update item in openhabian config today.

Needless to say I updated from 2.5m1 to 2.5m2. Not a big problem all seems to be working except hue emulation. I am not sure if the problem is related to my attempt at deconz install which appears to run on port 80 also or the m2 update. I had a couple questions.

Is there a way for me to manually install 2.5m1 again?
If not was there any changes to the hue emulation pertaining to configuration files? I can see that hue emulation is still installed I had no errors in the logs but Alexa is no longer able to connect. LOoking for some ideas of things I could try for debug. I tried going to openhabip/status and devices.xml and get page not found. Nginx appears to be running still as I can get to openHAB on port 80.

Your post got my attention because of the title. Is there any hidden joke I didn’t understand?

For how to install a specific (older or newer) version of the openhab2 packages see openHAB Milestone builds

1 Like

Yes my attention also this morning. I fixed the auto correct on my phone and it corrected anyway!

Looks like the command sudo apt install openhab2=2.5.0~M1-1 will install the old build!

Unfortunately, I broke something in my hue emulation when I installed deconz on the same port. I have removed deconz, but not sure what I broke in that process. Moving on and up to 2.5m2 on Buster! Was planning to do this today anyhow, so no big loss just a minor inconvenience!

This time I will get deconz working in my vm first prior to moving to my pi!
Thanks!

What a pity … great WAF, for sure :smile:

1 Like

@mstormi btw I realized I had not cleared my cache. So I stopped openHAB cleared it and restarted. My m1 install is working so the complete rebuild avoided.

I still plan to upgrade to m2 but my first attempt failed due to a bad usb drive. Planning on trashing that guy, it gave me an error in windows but I thought it was typical windows.