Upgraded to openHAB 2.2.0 Build #1047 massive issues

Hi,

Upgraded to openHAB 2.2.0 Build #1047 today, and now I’m getting issues.

  1. go to url on 8080 and i get a few interfaces, when going into them i’m getting 503 jetty not ready. Hit the url again and it says no interfaces are installed.

  2. go into the console. tab no longer works to show me the options.

If I backup uninstall and purge. Reinstall it works again. As soon as i drop my config back in and start up openhab it dies again.

openhab.log extract is below. Any pointers welcome. Thanks,

https://pastebin.com/fAWHhZHw

update

removed openhab2-addons and restarted openhab and it’s a lot happier.

Ah yes, there’s an issue tracking this at https://github.com/openhab/openhab-distro/issues/519.

Thanks benjy.

I’ll run without the openhab2-addons until it gets resolved.

It was confusing me as it worked when its first loaded, but not after a few mins.

Well if it just was that easy … I’m seeing #1047 issues, too, and depend on those addons :frowning:
The issue seems to be worked on right this morning. Plus there’s a new set of ESH fixes (#230) so we can expect both to appear in the next OH snapshot.

Addons install ok, but they are the ones in the online repo. Everything seems to be working for now now apart from the LIRC binding, but that’s new so I’m not sure if I have set it up correctly.

#1048 is out…

Ooo, have you upgraded yet?

upgrading right now…

1 Like