I have bought a newer, better desktop PC and migrating devismart binding development to it. On my laptop the IDE has been setup in 2.5.0-SNAPSHOT times and everything worked.
So, i have followed Eclipse setup instructions at https://www.openhab.org/docs/developer/ide/eclipse.html , so i’ve got the infrastructure plus two git repos checked out. I have added my devismart binding to pom.xml files; everything went fine until i tried to build the project. Everything failed.
I have found out that i needed to fix version number in my binding (the new infra expects 2.5.2-SNAPSHOT instead of 2.5.0-SNAPSHOT), and also in openhab-distro/launch/app/pom.xml the version was still set to 2.5.1-SNAPSHOT. After this i was able to build, but “Resolve” in app.bndrun now gives:
Resolution failed. Capabilities satisfying the following requirements could not be found:
⇒ osgi.identity: (osgi.identity=org.openhab.binding.devireg)
⇒ [org.openhab.binding.devireg version=18.104.22.168002202224]
⇒ osgi.wiring.package: (&(osgi.wiring.package=net.minidev.json)(&(version>=2.3.0)(!(version>=3.0.0))))
⇒ [net.minidev.json-smart version=2.3.0]
⇒ osgi.wiring.package: (&(osgi.wiring.package=net.minidev.asm)(&(version>=1.2.0)(!(version>=2.0.0))))
⇒ [net.minidev.accessors-smart version=1.2.0]
⇒ osgi.wiring.package: (&(osgi.wiring.package=org.objectweb.asm)(&(version>=5.0.0)(!(version>=6.0.0))))
Apparently there’s something broken. It looks like it cannot find appropriate version of org.objectweb.asm. I’ve checked openhab-addons repo, some bindings still refer to net.minidev.json v2.3. So it should be valid. Can anyone explain me how to fix this ?
Meanwhile i’ll try to roll back to earlier commits of the infrastructure repo. May be 2.5.1 release will work.