Upgrading OH2 Beta4 => OH2 Stable


Using Raspberry PI with openHAB 2 beta 4 since a while but now want to take the step to upgrade to openHAB2 stable.
Have APT and changed from

deb http://dl.bintray.com/openhab/apt-repo2 testing main


deb http://dl.bintray.com/openhab/apt-repo2 stable main

then running

apt-get update
apt-get upgrade

But nothing gets upgraded?!

I guess I miss something, or?
Do I need to go for clean install?

Hi, this is exactly what I did a while ago, and it worked like a charm. Definitely no need for a clean install. Perhaps I am stating the obvious here, but the apt-get update and apt-get upgrade should be run as root, I did:

sudo apt-get update
sudo apt-get upgrade

I would guess you did that as well (otherwise you should have seen error messages), but who knows …

The repo has moved.

That topic refers to snapshots only, right. It seems the original poster wants the stable (like me). I believe he has the correct repo for that, or are we both mistaken?

deb http://dl.bintray.com/openhab/apt-repo2 stable main

I have tried to clean up apt-get and running both

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

Karaf still says:

183 | Active   |  80 | 0.9.0.b1              | Eclipse SmartHome Basic UI, Fragments: 187
184 | Active   |  80 | 0.9.0.b1              | Eclipse SmartHome WebApp UI
185 | Active   |  80 | 0.9.0.b1              | Eclipse SmartHome Paper UI, Fragments: 190
186 | Active   |  80 | 2.0.0.b4              | openHAB REST Documentation
187 | Resolved |  80 | 2.0.0.b4              | openHAB Basic UI Fragment, Hosts: 183
188 | Active   |  80 | 2.0.0.b4              | openHAB Classic UI Fragment
189 | Active   |  80 | 2.0.0.b4              | openHAB Dashboard UI
190 | Resolved |  80 | 2.0.0.b4              | openHAB Paper UI Theme Fragment, Hosts: 185

Then apt-get update ignore eventhough I have cleaned lists:

pi@rpi-openhab:~ $ sudo ls -al /var/lib/apt/lists
total 12
drwxr-xr-x 3 root root 4096 Mar  5 14:32 .
drwxr-xr-x 5 root root 4096 Mar  5 14:09 ..
-rw-r----- 1 root root    0 Nov 27 10:42 lock
drwxr-xr-x 2 root root 4096 Mar  5 14:31 partial

pi@rpi-openhab:~ $ sudo apt-get clean
pi@rpi-openhab:~ $ sudo apt-get autoclean
Reading package lists... Done
Building dependency tree
Reading state information... Done

pi@rpi-openhab:~ $ sudo apt-get update
Get:1 http://archive.raspberrypi.org jessie InRelease [22.9 kB]
Ign http://dl.bintray.com stable InRelease
Get:2 http://mirrordirector.raspbian.org jessie InRelease [14.9 kB]
Get:3 http://dl.bintray.com stable Release.gpg [821 B]
Get:4 http://dl.bintray.com stable Release [6,050 B]
Get:5 http://archive.raspberrypi.org jessie/main armhf Packages [147 kB]
Get:6 http://mirrordirector.raspbian.org jessie/main armhf Packages [8,980 kB]
Get:7 http://archive.raspberrypi.org jessie/ui armhf Packages [57.6 kB]
Get:8 http://dl.bintray.com stable/main armhf Packages [666 B]
Ign http://dl.bintray.com stable/main Translation-en_GB
Ign http://dl.bintray.com stable/main Translation-en
Ign http://archive.raspberrypi.org jessie/main Translation-en_GB
Ign http://archive.raspberrypi.org jessie/main Translation-en
Get:9 http://mirrordirector.raspbian.org jessie/contrib armhf Packages [37.5 kB]
Ign http://archive.raspberrypi.org jessie/ui Translation-en_GB
Get:10 http://mirrordirector.raspbian.org jessie/non-free armhf Packages [70.3 kB]
Get:11 http://mirrordirector.raspbian.org jessie/rpi armhf Packages [1,356 B]
Ign http://archive.raspberrypi.org jessie/ui Translation-en
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en
Ign http://mirrordirector.raspbian.org jessie/main Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/main Translation-en
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en
Fetched 9,339 kB in 20s (454 kB/s)
Reading package lists... Done

pi@rpi-openhab:~ $ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

I think I found the issue…
Been using OH2 since a while and upgraded beta versions without a problem. Today I gave up and went for a clean install…couldn’t find openhab2 but openhab2-online was installed. I guess that was the reason for not upgrading.
So removed it and installed openhab2 and need to do some other reinstalls as well.