UPnP based discovery does not work on host networked docker container

I have experienced that not all components of OpenHAB use the Primary Address setting (that you have shown above).

It’s good to know that the network interface to use can be configured for the UPnP component though, but it would be much better if it would use the central Primary Address setting.

I did not yet continue with this, I put it aside as in the meantime I got a lot of other things to do.
I hope I can get back to this soon.
To also say something useful: not long after opening this discussion, I also opened an issue that I think is relevant. There was an attempt to fix it, and probably it has been merged by now.