USB Z-Wave Stick not coming online

I’m currently migrating my setup from OH2 to OH3.1 and have come across an issue getting my Z-Wave controller to come online.

I’m running CentOS 8 and installed via the repository as per the documentation. When I switch my USB stick over I get the following error.

[INFO ] [zwave.handler.ZWaveControllerHandler] - Attempting to add listener when controller is null

OH is running with the openhab user which is a member of the dialout & tty groups. The device is reported as /dev/ttyACM0.

The same configuration works fine on my OH2 server, although that’s running on CentOS 7.

Any pointers would be very much appreciated as this is the last step of my migration plan.

Maybe a permission issue? I would do a chmod 777 to check.

Tried that and still get the same error. Good thought, but sadly didn’t help this time.

Not a solution but the following 3 lines are normal;

2021-08-09 10:38:56.228 [INFO ] [zwave.handler.ZWaveControllerHandler] - Attempting to add listener when controller is null
2021-08-09 10:39:01.496 [INFO ] [ve.internal.protocol.ZWaveController] - Starting ZWave controller
2021-08-09 10:39:01.500 [INFO ] [ve.internal.protocol.ZWaveController] - ZWave timeout is set to 5000ms. Soft reset is false.

Although the log may not be long, Change the zwve log level to Debug to maybe see why it is not proceeding to the second INFO.


Thanks @apella12 but I don’t get the additional two lines in my log. My controller doesn’t go online at all.

Found the solution here

Took a bit of searching to get there. Hopefully this will help others.

1 Like